描述You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take?


输入

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

输出

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!

样例输入

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

样例输出

Escaped in 11 minute(s).
Trapped!

题目大意:在3d迷宫内某一层的一点起步,中间变换楼层,躲避障碍,最终能否走到终点,如果能,输出最少步数。
#include<iostream>
#include<map>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;
int l,r,c,u_d,el;
int xx[4]={0,0,1,-1},yy[4]={1,-1,0,0};
struct L
{
  char M[35][35];

}L[35];
typedef struct Node
{
   int x,y,l,step;
} Node;
int BFS(int x,int y,int l0)
{
 queue<Node>Q;
 Node t,temp;
 t.x=x;
 t.y=y;
 t.l=l0;
 t.step=0;
 Q.push(t);
 while(!Q.empty())
 {
   t=Q.front();
   Q.pop();
   if(t.x<0||t.x>=r||t.y<0||t.y>=c||L[t.l].M[t.x][t.y]=='#')
    continue;
   if(L[t.l].M[t.x][t.y]=='E')return t.step;//找到出口
   L[t.l].M[t.x][t.y]='#';
   if(t.l<l-1&&L[t.l+1].M[t.x][t.y]!='#')//能够前往迷宫下层
    {
        temp=t;
        temp.l=t.l+1;
        temp.step=t.step+1;
        Q.push(temp);
    }
    if(t.l>0&&L[t.l-1].M[t.x][t.y]!='#')//能够前往迷宫上层
    {
        temp=t;
        temp.l=t.l-1;
        temp.step=t.step+1;
        Q.push(temp);
    }
    for(int i=0;i<4;i++)//迷宫内左右移动
    {
       temp=t;
       temp.x=t.x+xx[i];
       temp.y=t.y+yy[i];
       temp.step=t.step+1;
       Q.push(temp);
    }
 }
   return -1;
}

int main()
{
 int x0,y0,l0;
 while(cin>>l>>r>>c&&l!=0&&r!=0&&c!=0)
 {
   for(int i=0;i<l;i++)
   {
      for(int j=0;j<r;j++)
        for(int k=0;k<c;k++)
         {
             cin>>L[i].M[j][k];
             if(L[i].M[j][k]=='S'){x0=j;y0=k;l0=i;}
             else if(L[i].M[j][k]=='E'){el=i;}
         }

   }
   int t=(BFS(x0,y0,l0));
   if(t==-1)cout<<"Trapped!"<<endl;
    else cout<<"Escaped in "<<t<<" minute(s)."<<endl;
 }

  return 0;
}

 

 posted on 2020-02-14 10:49  古拉多  阅读(170)  评论(0编辑  收藏  举报