鸿蒙运行报错:Failure[INSTALL_PARSE_FAILED_USESDK_ERROR] Error while Deploying HAP

问题描述

近期,使用DevEco-Studio新建手机类型的工程,编译成功,发布到模拟器(鸿蒙P40)时出错,如下图:

原因分析

本地DevEco-Studio使用的SDK版本与设备(P40)不匹配导致【鸿蒙技术人员答复】;

解决办法

方案1:将config.json中的apiVersion->releaseType删除掉(很神奇:releaseType是创建工程自带的配置信息,竟然会报错),如下图:

方案2:升级最新版IDE(我本地IDE仅支持SDK3和4版本,目前最新的SDK是5了)

问题总结

我这边IDE版本是2.1 beta2。

使用本地IDE,重新创建项目,无论选择SDK3还是4,都会报Failure[INSTALL_PARSE_FAILED_USESDK_ERROR] ;

该问题应该是华为IDE自身兼容性的BUG,希望新版本IDE能修复该问题。

posted @ 2021-04-02 09:51  齐行超  阅读(1783)  评论(0编辑  收藏  举报