Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题意:题目的意思是,两个人在玩游戏之前,需要把草堆全部清除掉。他们两个可以选择同一个草堆点燃,也可以选择不同的(但只能点燃一次,此外火势是可以蔓延的时间为1分钟)。

问是否可以清除(燃烧)所有的草堆,若能的话输出做小的燃烧时间,不能就请输出-1。

思路:首先草堆的数量小于等于2,肯定是能烧完的,此时时间输出为0

其他情况:开始的两个着火点可以相同或者不同,所以我们对所有的草堆进行两两组合,以这两个草堆为着火点同时进行广搜

如果燃烧的草堆数量等于草堆数量,则返回时间;否则返回-1

注意:代码实现有很多注意事项,详见code

代码:
import java.util.ArrayDeque;
import java.util.Arrays;
import java.util.Scanner;
class Node{
        int x;
        int y;
        int step;
        public Node(int x,int y,int step){
                this.x=x;
                this.y=y;
                this.step=step;
        }
}
public class Main{
        static int n,m,c,cnt;
        static final int N=15;
        static final int INF=2147483647;
        static char map[][]=new char[N][N];
        static boolean vis[][]=new boolean[N][N];
        static ArrayDeque<Node> q=new ArrayDeque<Node>();
        static Node node[]=new Node[N*N];
        static int dx[]={0,0,1,-1};
        static int dy[]={1,-1,0,0};
        static int bfs(Node t1,Node t2){
                //每次广搜每次初始化、清空
                for(int i=0;i<N;i++) Arrays.fill(vis[i], false);
                while(!q.isEmpty()) q.poll();
                q.offer(new Node(t1.x,t1.y,0));
                q.offer(new Node(t2.x,t2.y,0));
                vis[t1.x][t1.y]=true;
                vis[t2.x][t2.y]=true;
                //必须判断是否为同1个点
                if(t1.x==t2.x && t1.y==t2.y) cnt=1;
                else cnt=2;
//                System.out.println("t1.x="+t1.x+" t1.y="+t1.y+" cnt="+cnt);
                while(!q.isEmpty()){
                        Node t=q.poll();
                        for(int i=0;i<4;i++){
                                int xx=t.x+dx[i];
                                int yy=t.y+dy[i];
                                if(xx<0||yy<0||xx>=n||yy>=m||vis[xx][yy]||map[xx][yy]!='#') continue;
                                vis[xx][yy]=true;
                                cnt++;
                                if(cnt==c) return t.step+1;
                                q.offer(new Node(xx,yy,t.step+1));
                        }
                }
                return -1;
        }
        public static void main(String[] args) {
                Scanner scan=new Scanner(System.in);
                int T=scan.nextInt();
                for(int k=1;k<=T;k++){
                        n=scan.nextInt();
                        m=scan.nextInt();
                        for(int i=0;i<n;i++) map[i]=scan.next().toCharArray();
                        c=0;
                        for(int i=0;i<n;i++)
                            for(int j=0;j<m;j++)
                                    if(map[i][j]=='#'){
                                            node[c++]=new Node(i,j,0);
                                    }
                        if(c<=2) {
                                System.out.println("Case "+k+": 0");    
                                continue;
                        }
                        int ans=INF;
                        for(int i=0;i<c;i++)
                            for(int j=i;j<c;j++){
                                    int  res=bfs(node[i],node[j]);//这里错搞了2次bfs
                                    if(res!=-1) ans=Math.min(ans, res);
                            }
                        if(ans==INF) System.out.println("Case "+k+": -1");
                        else System.out.println("Case "+k+": "+ans);
                }
        }
 }

 

posted on 2020-02-01 11:53  qdu_lkc  阅读(198)  评论(0编辑  收藏  举报