uname -r和在usr/src下的版本号不一致

 

转至 http://my.oschina.net/dbmzlinux/blog/55912

 

问题的原因:安装vm_tools过程中提示找不到GCC header

解决方法如下:

大概步骤分10步:

  1.安装c编译器

  2.安装kernel-devel

  3.检查kernel跟kernel-devel的版本号

  4.两个版本号不一致,进行升级

  5.再次检查版本号,还不一致,需要重启。

  6.重启后,版本号一致。

  7.用ls命令查看匹配kernel的c编译器的header的路径

  8.安装vmware-tool

  9.选择屏幕分辨率。

  10.还要修改xorg config设置

详细如下:

  1.安装c编译器

[root@dbmz  dbmz]# yum install gcc  

2.安装kernel-devel

[root@dbmz  dbmz]# yum install kernel-devel

  3.检查kernel跟kernel-devel的版本号

[root@dbmz  dbmz]# uname -r
2.6.35.6-45.fc14.i686  
[root@dbmz  dbmz]# rpm -q kernel
 kernel-devel-2.6.35.14-106.fc14.i686

  4.两个版本号不一致,进行升级

[root@dbmz  dbmz]# yum -y update kernel kernel-devel

  5.再次检查版本号,还不一致,需要重启。

[root@dbmz  dbmz]# uname -r
2.6.35.6-45.fc14.i686  
[root@dbmz  dbmz]# rpm -q kernel
 kernel-devel-2.6.35.14-106.fc14.i686

  6.重启后,版本号一致。

[root@dbmz  dbmz]# reboot
[root@dbmz  dbmz]# uname -r
 kernel-devel-2.6.35.14-106.fc14.i686
[root@dbmz  dbmz]# rpm -q kernel
 kernel-devel-2.6.35.14-106.fc14.i686

  7.用ls命令查看匹配kernel的c编译器的header的路径

ls -d /usr/src/kernels/$(uname -r)*/include

        在我这里,路径为"/usr/src/kernels/2.6.35.14-106.fc14.i686/include",也就是uname -r的结果,版本信息。(实际上,我没有记下来,后面安装vmware-tool时,它自动识别出来了) 

8.安装vmware-tool

这个过程就略啦,一路"Enter"狂奔吧~~

9.选择屏幕分辨率。

        略,你懂的。

10.还要修改xorg config设置

        网上这么说,此处必须要修改,否则你重启后会报X-Windows出错。
进入/etc/X11/,用文本打开xorg.conf,要添加一些东西。

        可是我在此目录下并没有找到这个配置文件,而且直接重启了也没有报X-Windows出错。

        我觉得可能和第9步有关系,我没有对分辨率作调整。重启以后直接可以网虚拟机里面拖拉文件啦。

Done~ 

 

posted on 2014-11-27 23:52  我爱江安二餐盐煎肉  阅读(662)  评论(0编辑  收藏

导航