2012年浙大:Sharing

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

输入:

For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

输出:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

样例输入:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
样例输出:
67890
-1
题目来源:http://ac.jobdu.com/problem.php?pid=1468
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=100005;
struct Node{
    int fr,ed;
    char ch;
}no[MAXN];
struct Str{
    char s[MAXN];
    int pos[MAXN];
    int len;
    Str()
    {
        memset(s,0,sizeof(s));
        len=0;
    }
};
int HASH[MAXN];
void Handle(int next,Str &a)
{
    while(next!=-1)
    {
        int now=HASH[next];
        a.s[a.len]=no[now].ch;
        a.pos[a.len]=next;
        next=no[now].ed;
        a.len++;
    }
}
int head,rear,n;
int main()
{
    
    while(scanf("%d%d%d",&head,&rear,&n)!=EOF)
    {
        memset(HASH,0,sizeof(HASH));
        for(int i=0;i<n;i++)
        {
            scanf("%d %c %d",&no[i].fr,&no[i].ch,&no[i].ed);
            HASH[no[i].fr]=i;
        }
        Str a;
        Str b;
        Handle(head,a);
        Handle(rear,b);
        int res=-1;
        for(int i=a.len-1,j=b.len-1;i>=0&&j>=0;i--,j--)
        {
            if(a.s[i]!=b.s[j])    break;
            res=a.pos[i];
        }
        if(res!=-1)
            printf("%05d\n",res);//输出5个数字,不足前导补0
        else
            printf("-1\n");
    }
    
    return 0;
}

 

 

posted on 2016-03-24 20:25  vCoders  阅读(116)  评论(0编辑  收藏  举报

导航