POJ1276(多重背包)

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30973   Accepted: 11161

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

记忆化搜索TLE
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int m,n;
int w[15],b[15];
int dp[100005];
int dfs(int dep,int wei)
{
    if(dp[wei]>0)
        return dp[wei];
    if(dep==n)
    {
        return dp[wei]=(wei==0);
    }
    int res=0;
    for(int k=0;k<=b[dep]&&wei>=w[dep]*k;k++)
    {
        res=(res|dfs(dep+1,wei-w[dep]*k));
    }
    return dp[wei]=res;
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&b[i],&w[i]);
        }
        for(int i=m;i>=0;i--)
        {
            if(dfs(0,i)>0)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    
    return 0;
}

 


多重部分和模板
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cash,n;
int a[15],m[15];
int dp[100005];
int main()
{
    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&m[i],&a[i]);
        }
        dp[0]=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<=cash;j++)
                if(dp[j]>=0)
                    dp[j]=m[i];
                else if(j<a[i]||dp[j-a[i]]<0)
                    dp[j]=-1;
                else    
                    dp[j]=dp[j-a[i]]-1;
        
        for(int i=cash;i>=0;i--)
            if(dp[i]>=0)
            {
                printf("%d\n",i);
                break;
            }
    }
    
    return 0;
}

转化为多重背包

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cash,n;
int w[10005];
int dp[100005];
int main()
{
    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            int num,v;
            scanf("%d%d",&num,&v);
            int e=1;
            while(e<num)
            {
                w[cnt++]=e*v;
                num-=e;
                e<<=1;
            }        
            if(num>0)
                w[cnt++]=num*v;
        }
        
        for(int i=0;i<cnt;i++)
            for(int j=cash;j>=w[i];j--)
                dp[j]=max(dp[j],dp[j-w[i]]+w[i]);
        
        printf("%d\n",dp[cash]);
    }
    
    return 0;
}

 滚动数组:

import java.util.Arrays;
import java.util.Scanner;
public class Main{
    static Scanner in =new Scanner(System.in);
    static int MAXN=100005;
    static int[] v=new int[MAXN];
    static int[][] dp=new int[2][MAXN];
    static int cash,n,top;
    public static void main(String[] args){
        
        while(in.hasNext())
        {
            Arrays.fill(dp[0], 0);
            top=0;
            cash=in.nextInt();
            n=in.nextInt();
            for(int i=0;i<n;i++)
            {
                int c,val;
                c=in.nextInt();
                val=in.nextInt();
                int k=1;
                while(k<=c)
                {
                    v[top++]=k*val;
                    c-=k;
                    k<<=1;
                }
                if(c!=0)
                {
                    v[top++]=c*val;
                }
            }
            for(int i=0;i<top;i++)
            {
                for(int j=0;j<=cash;j++)
                {
                    if(j<v[i])
                    {
                        dp[(i+1)&1][j]=dp[i&1][j];
                    }
                    else
                    {
                        dp[(i+1)&1][j]=Math.max(dp[i&1][j], dp[i&1][j-v[i]]+v[i]);
                    }
                }
            }
            System.out.println(dp[n&1][cash]);
        }
    }
}

 

posted on 2016-02-25 11:08  vCoders  阅读(435)  评论(0编辑  收藏  举报

导航