HUD1686(KMP入门题)

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8732    Accepted Submission(s): 3526


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

 

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
 
Sample Output
1
3
0
#include<cstdio>
#include<cstring>
using namespace std;
char W[10005],T[1000005];
int lenW,lenT;
int next[10005];
void getnext()
{
    int i=0,k=-1;
    next[0]=-1;
    while(i<lenW)
    {
        if(k==-1||W[i]==W[k])
        {
            i++;
            k++;
            next[i]=k;
        }
        else    k=next[k];
    }
}
int KMP()
{
    getnext();
    int i=0,j=0;
    int  cnt=0;
    while(i<lenT)
    {
        if(j==-1||W[j]==T[i])
        {
            i++;
            j++;
        }
        else    j=next[j];
        if(j==lenW)
        {
            cnt++;
            j=next[j];//若两个不同的匹配中有交集则j=next[j],若没有交集j=0; 
        }
    }
    return cnt;
}
int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
           memset(next,0,sizeof(next));
           scanf("%s%s",W,T);
           lenW=strlen(W);
           lenT=strlen(T);
           printf("%d\n",KMP());
   }
   
    return 0;
}

 字符串Hash

#include<cstdio>
#include<cstring>
using namespace std;
typedef unsigned long long ull;
const ull B=100000007;
const int MAXN=1000005;
char a[MAXN],b[MAXN];
int lena,lenb;
ull t;
ull ah;
ull bh[MAXN];
void getah()
{
    for(int i=0;i<lena;i++)
        t*=B;
    for(int i=0;i<lena;i++)
        ah=ah*B+a[i];
}
void getbh()
{
    ull h=0;
    for(int i=0;i<lena;i++)
        h=h*B+b[i];
    bh[0]=h;
    for(int i=lena;i<lenb;i++)
        bh[i-lena+1]=bh[i-lena]*B+b[i]-b[i-lena]*t;
}
int KMP()
{
    int cnt=0;
    memset(bh,0,sizeof(bh));
    getah();
    getbh();
    for(int i=0;i<lenb-lena+1;i++)
        if(ah==bh[i])    cnt++;
    return cnt;
}
int n;
int main(){
    
    while(scanf("%d",&n)!=EOF)
    {
        while(n--)
        {
            ah=0;
            t=1;
            scanf("%s",a);
            scanf("%s",b);
            lena=strlen(a);
            lenb=strlen(b);    
            printf("%d\n",KMP());
        }
    }
    
    return 0;
}

 

posted on 2016-02-18 12:01  vCoders  阅读(290)  评论(0编辑  收藏  举报

导航