POJ2184(01背包变形)

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11092   Accepted: 4404

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8
题意:给出n个奶牛,每个奶牛有ts之和tf值,从中选出一些奶牛使ts+tf之和最大且ts之和与tf之和均非负.
思路:选与不选的问题,转化为01背包。将ts作为体积,tf作为价值。
#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
const int MAXN=200005;
const int INF=0x3fffffff;
int dp[MAXN];
int n;
int ts[MAXN],tf[MAXN];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<MAXN;i++)    dp[i]=-INF;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&ts[i],&tf[i]);
        }
        dp[100000]=0;
        for(int i=0;i<n;i++)
        {
            if(ts[i]<0&&tf[i]<0)    continue;
            if(ts[i]>0)
            {
                for(int j=200000;j>=ts[i];j--)//体积大于0时倒序 
                    dp[j]=max(dp[j],dp[j-ts[i]]+tf[i]);
            }
            else
            {
                for(int j=0;j<=200000+ts[i];j++)//体积小于0时正序 
                    dp[j]=max(dp[j],dp[j-ts[i]]+tf[i]);
            }
        }
        int maxn=-INF;
        for(int i=100000;i<=200000;i++)
        {
            if(dp[i]>=0)
                maxn=max(maxn,dp[i]+i-100000);    
        }
        
        if(maxn>0)    printf("%d\n",maxn);
        else    printf("0\n");
        
    }
    
    return 0;
}

 

posted on 2016-02-13 21:53  vCoders  阅读(277)  评论(0编辑  收藏  举报

导航