FastAPI - 解决运行 uvicorn 报错 ImportError: email-validator is not installed, run `pip install pydantic[email]`

背景

from pydantic import BaseModel, EmailStr

class UserIn(BaseModel):
    username: str
    password: str
    email: EmailStr
    full_name: Optional[str] = None

定义的 Pydantic Model 某个字段声明为 EmailStr 类型

运行 uvicorn 服务器的时候报错

ImportError: email-validator is not installed, run `pip install pydantic[email]`

 

根因

缺少 email_validator 库

 

解决方法

pip install email_validator

 

注意

虽然它提示了解决方法,但很大可能会提示你

> pip install pydantic[email]  
zsh: no matches found: pydantic[email]

 

posted @ 2021-09-21 18:09  小菠萝测试笔记  阅读(65)  评论(0编辑  收藏  举报