Python - poetry(1)包管理利器的入门介绍

Python 虚拟环境详解

https://www.cnblogs.com/poloyy/p/15266382.html

 

poetry 官方介绍

github:https://github.com/python-poetry/poetry

文档(要🪜):https://python-poetry.org/docs/

 

poetry 民间介绍

  • 用 poetry 来同时管理 Python 库和 Python 程序
  • poetry 可以管理 Python 依赖包、虚拟环境,同时可以用于 Python 工程打包和发布的一款第三方工具包
  • poetry 通过配置文件 pyproject.toml 来完成依赖管理、环境配置、基本信息配置等功能,相当于把 Python 项目中的 Pipfile、setup.py、setup.cfg、requirements.txt、MANIFEST.in 融合到一起
  • 通过 pyproject.toml 文件,不仅可以配置依赖包,还可以用于区分开发、测试、生产环境、配置源路径

 

poetry 的优势

  • 更强大的依赖处理功能
  • 易于打包和构建Python工程
  • 易于发布工具包
  • 结构化展示依赖关系

 

依赖处理

pipenv 在 安装包的时候如果找不到它对应版本的依赖包会直接报错

> pipenv install oslo.utils==1.4.0
Could not find a version that matches pbr!=0.7,!=2.1.0,<1.0,>=0.6,>=2.0.0

  

但是 poetry 有强大的依赖处理能力,并不会报错

> poetry add oslo.utils=1.4.0
  - Installing pytz (2018.3)
  - Installing netifaces (0.10.6)
  - Installing netaddr (0.7.19)
  - Installing oslo.i18n (2.1.0)
  - Installing iso8601 (0.1.12)
  - Installing six (1.11.0)
  - Installing babel (2.5.3)
  - Installing pbr (0.11.1)
  - Installing oslo.utils (1.4.0)
  • poetry 在遇到 pbr (>=0.6,!=0.7,<1.0) 这个限定条件时,它会尝试去安装最新的 pbr(0.11.1),同时会选择 oslo.i18n==3.20.0
  • 但是,这时候发现 oslo.i18n 的版本和 pbr 最新版本冲突
  • 如果在 pipenv 中则会报错(像上面一样)
  • 但是 poetry 会尝试找出解决方案,最后发现 oslo.i18n==2.1.0 是可以满足所有包的相互依赖关系的要求
  • 最终,成功安装依赖包

 

易于打包、构建 python 工程

  •  在工程开发过程中,项目迁移和工程化部署是无法绕开的问题
  •  如果需要把工程部署到生产环境服务器上,这时候就需要用到 Python 的打包和安装功能
  •  在以往,会写繁琐的 setup.py、setup.cfg
  • 而在poetry中,一行命令就可以解决
> poetry build
​
Building poetry (1.0.0)
- Building sdist
- Built poetry-1.0.0.tar.gz
​
- Building wheel
- Built poetry-1.0.0-py2.py3-none-any.whl

 

易于发布工具包

  • 如果想要把工程发布到 PyPI 仓库怎么办? 
  • 在 poetry 中,只需要简单配置一下 pyproject.toml,就可以实现一行命令发布工具包
> poetry publish
​
Publishing poetry (1.0.0) to PyPI
​
  - Uploading poetry-1.0.0.tar.gz 100%
  - Uploading poetry-1.0.0-py2.py3-none-any.whl 58%

 

结构化展示依赖关系 

  1. Python 是一个对第三方工具包依赖很强的一种编程语言
  2. 一个项目中会用到很多个不同的依赖包,不同包的依赖关系可能会很复杂
  3. poetry 可以实现结构化(tree 的形式)展示每个包的依赖关系,让工程的依赖一目了然
> poetry show --tree
requests-toolbelt 0.8.0 A utility belt for advanced users...
└── requests <3.0.0,>=2.0.1
    ├── certifi >=2017.4.17
    ├── chardet >=3.0.2,<3.1.0
    ├── idna >=2.5,<2.7
    └── urllib3 <1.23,>=1.21.1> poetry show --latest
pendulum 2.0.4   1.4.5 Python datetimes made easy.
django   1.11.11 2.0.3 A high-level Python Web framework ...
requests 2.18.4  2.18.4 Python HTTP for Humans.

 

安装

linux、mac 下安装

curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/install-poetry.py | python -

 

window 下安装

(Invoke-WebRequest -Uri https://raw.githubusercontent.com/python-poetry/poetry/master/install-poetry.py -UseBasicParsing).Content | python -

 

使用官方 git repository 来安装

python install-poetry.py --git https://github.com/python-poetry/poetry.git@master

 

卸载

python get-poetry.py --uninstall

 

完全删除 poetry

python install-poetry.py --uninstall
POETRY_UNINSTALL=1 python install-poetry.py

 

更新到最新的稳定版本

poetry self update

 

更新到预发布版本

poetry self update --preview

 

通过 pipx 安装、更新、卸载

安装 pipx

pip install pipx

 

安装、更新、卸载

pipx install poetry

pipx upgrade poetry

pipx uninstall poetry

 

posted @ 2021-09-14 14:43  小菠萝测试笔记  阅读(98)  评论(0编辑  收藏  举报