[Usaco2008 Nov]Guarding the Farm 保卫牧场[DFS]

Description

The farm has many hills upon which Farmer John would like to place guards to ensure the safety of his valuable milk-cows. He wonders how many guards he will need if he wishes to put one on top of each hill. He has a map supplied as a matrix of integers; the matrix has N (1 < N <= 700) rows and M (1 < M <= 700) columns. Each member of the matrix is an altitude H_ij (0 <= H_ij <= 10,000). Help him determine the number of hilltops on the map. A hilltop is one or more adjacent matrix elements of the same value surrounded exclusively by either the edge of the map or elements with a lower (smaller) altitude. Two different elements are adjacent if the magnitude of difference in their X coordinates is no greater than 1 and the magnitude of differences in their Y coordinates is also no greater than 1.

 

农夫JOHN的农夫上有很多小山丘,他想要在那里布置一些保镖(……)去保卫他的那些相当值钱的奶牛们。 他想知道如果在一座小山丘上布置一名保镖的话,他总共需要招聘多少名保镖。他现在手头有一个用数字矩阵来表示地形的地图。这个矩阵有N行(1 < N < = 100)和M列( 1 < M < = 70) 。矩阵中的每个元素都有一个值H_ij(0 < = H_ij < =10,000)来表示该地区的海拔高度。请你帮助他统计出地图上到底有多少个小山丘。 小山丘的定义是:若地图中一个元素所邻接的所有元素都比这个元素高度要小(或它邻接的是地图的边界),则该元素和其周围所有按照这样顺序排列的元素的集合称为一个小山丘。这里邻接的意义是:若一个元素与另一个横坐标纵坐标和它的横纵坐标相差不超过1,则称这两个元素邻接。 问题名称:guard 输入格式: 第一行:两个由空格隔开的整数N和M 第二行到第N+1行:第I+1行描述了地图上的第I行,有M个由空格隔开的整数:H_ij. 输入样例:(guard.in): 8 7 4 3 2 2 1 0 1 3 3 3 2 1 0 1 2 2 2 2 1 0 0 2 1 1 1 1 0 0 1 1 0 0 0 1 0 0 0 0 1 1 1 0 0 1 2 2 1 1 0 0 1 1 1 2 1 0 输出格式: 第一行:小山丘的个数 输出样例:(guard.out): 3 输出样例解释: 地图上有三个小山丘:每个小山丘的山峰位置分别在左上角(高度为4),右上角(高度为1)和底部(高度为2)。

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes row i of the matrix with M space-separated integers: H_ij

Output

* Line 1: A single integer that specifies the number of hilltops

Sample Input

8 7
4 3 2 2 1 0 1
3 3 3 2 1 0 1
2 2 2 2 1 0 0
2 1 1 1 1 0 0
1 1 0 0 0 1 0
0 0 0 1 1 1 0
0 1 2 2 1 1 0
0 1 1 1 2 1 0

Sample Output

3

HINT

 

   三个山丘分别是:左上角的高度为4的方格,右上角的高度为1的方格,还有最后一行中高度为2的方格.

题解:

其实就是求连通块的个数;

感觉有很多种求法的样子,bfs啊fillfoold啥的,貌似都可以;

我用了dfs;

为了不超时,所以先对h进行了排序;

 

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=701;
const int dx[9]={1,-1,0,0,1,-1,1,-1},dy[9]={1,-1,1,-1,0,0,-1,1};
struct node{
	int x,y,h;
}f[maxn*maxn];
int h[maxn][maxn];
int tot=0,ans=0,n,m;
bool vis[maxn][maxn];

bool cmp(const node &a,const node &b){
	return a.h>b.h?1:0;
}

void dfs(int x,int y){
	vis[x][y]=1;
	for(int i=0;i<8;i++){
		int xx=x+dx[i];
		int yy=y+dy[i];
		if(xx>=0 && xx<=n && yy>=0 && yy<=m && !vis[xx][yy] && h[x][y]>=h[xx][yy]) dfs(xx,yy);
	}
}
int main(){
	freopen("guardian.in","r",stdin);
	freopen("guardian.out","w",stdout);
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
	    for(int j=1;j<=m;j++){
	       scanf("%d",&h[i][j]);
	       f[++tot].h=h[i][j];
		   f[tot].x=i;
		   f[tot].y=j;	
	    }
	sort(f+1,f+tot+1,cmp);
	for(int i=1;i<=tot;i++){
		if(!vis[f[i].x][f[i].y]){
			dfs(f[i].x,f[i].y);
			ans++;
		}
	}
    cout<<ans;
	return 0;
}

 

posted @ 2014-10-28 23:24  polebug  阅读(311)  评论(0编辑  收藏  举报