返回顶部
大江东去,浪淘尽,千古风流人物。故垒西边,人道是,三国周郎赤壁。乱石穿空,惊涛拍岸,卷起千堆雪。江山如画,一时多少豪杰。遥想公瑾当年,小乔初嫁了,雄姿英发。羽扇纶巾,谈笑间,樯橹灰飞烟灭。故国神游,多情应笑我,早生华发。人生如梦,一尊还酹江月。

poj3046

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.

Input

* Line 1: 4 space-separated integers: T, A, S, and B

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS:

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?


OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members
 
dp[i][j]表示前i类选0-j个方案数
则转移方程为dp[i][j]=dp[i][j-1]-dp[i-1][j-num[i]-1]+dp[i-1][j]
用滚动数组将空间压为一维
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int mod = 1e6;

int n,m,s,b,num[1100],f[100005];

int main(){
    while(scanf("%d%d%d%d",&n,&m,&s,&b)!=EOF){
        memset(num,0,sizeof(num));
        for(int i=1;i<=m;i++){
            int a;scanf("%d",&a);
            num[a]++;
        }
        for(int i=0;i<=b;i++) f[i]=1;
        for(int i=1;i<=n;i++){
            for(int j=b;j>=0;j--){
                if(j>num[i]) 
                f[j]-=f[j-num[i]-1],f[j]=(f[j]+mod)%mod;
            }
            for(int j=1;j<=b;j++) 
            f[j]+=f[j-1],f[j]%=mod;
        }
        printf("%d\n",(f[b]-f[s-1]+mod)%mod);
    }
    return 0;
}

 

posted @ 2019-07-28 20:31  plysc  阅读(209)  评论(0编辑  收藏  举报