hdoj-1896 stones

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1375    Accepted Submission(s): 859


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
11 12
 
#include<stdio.h>
#include<algorithm>
#include<queue>
using namespace std;
struct Stone/*存放石头的坐标和扔的距离*/ 
{
	int x;
	int y;
};
bool operator< (Stone a,Stone b)/*队列排序,如果坐标相同则按照扔的距离排序*/ 
{
	if(a.x==b.x&&a.y>b.y) 
	return true;
	else return a.x>b.x;
}
int main()
{
	int t,n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&t);
		Stone temp;
		int sum=1;/*用sum来表示第几个要扔的石头*/ 
		priority_queue<Stone>q;/*定义一个队列*/
		for(int i=0;i<t;i++)
		{
			scanf("%d%d",&temp.x,&temp.y);
			q.push(temp);/*将每个数据存放到队列中去*/
		}
		while(!q.empty())/*队列不为空时就一直进行下去*/
		{
			temp=q.top();/*用temp来表示队顶元素,同时要出队*/
			q.pop();
			if(sum%2)/*第奇数个要扔的石头才能进入*/
			{
				temp.x+=temp.y;/*记录石头的位置*/
				q.push(temp);
			}
			sum++;
		}
		printf("%d\n",temp.x);
	}
	return 0;
}

posted @ 2015-07-28 17:45  上弦月307  阅读(113)  评论(0编辑  收藏  举报