Bone Collector(hdoj--2602--01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40331    Accepted Submission(s): 16756


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
	int v;
	int val;
}edge[1010];
int f[1010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(f,0,sizeof(f));
		memset(edge,0,sizeof(edge));
		int n,v;
		scanf("%d%d",&n,&v);
		for(int i=0;i<n;i++)
		scanf("%d",&edge[i].val);
		for(int i=0;i<n;i++)
		scanf("%d",&edge[i].v);
		for(int i=0;i<n;i++)
		{
			for(int j=v;j>=edge[i].v;j--)
			{
				f[j]=max(f[j],f[j-edge[i].v]+edge[i].val);
			}
		}
		printf("%d\n",f[v]);
	}
	return 0;
}


posted @ 2015-08-26 18:57  上弦月307  阅读(159)  评论(0编辑  收藏  举报