lightoj--1005--Rooks(组合数)

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Submit Status

Description

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.

Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.

Input

Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output

For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input

8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output

Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0

Source

Problem Setter: Jane Alam Jan

Submit Status


/*以前做组合数总是错,总算找到一种神器#include<stdio.h>
#include<string.h>
typedef long long LL;
LL c[33][33];
int main()
{
	int t;
	scanf("%d",&t);
	int Case=1;
	for(int i=1;i<=30;i++)
	{
		c[i][0]=c[i][i]=1;
		c[i][1]=i;
		for(int j=2;j<i;j++)
		{
			c[i][j]=c[i-1][j]+c[i-1][j-1];
		}
	}
	while(t--)
	{
		int n,k;
		LL sum;
		scanf("%d%d",&n,&k);
		if(n<k)
		{
			printf("Case %d: 0\n",Case++);
		}
		else 
		{
			sum=c[n][k]*c[n][k];
			for(int i=1;i<=k;i++)
			sum*=i;
			printf("Case %d: %lld\n",Case++,sum);
		}
	}
}

posted @ 2015-10-24 19:33  上弦月307  阅读(177)  评论(0编辑  收藏  举报