hdoj--5333--Dancing Stars on Me(水题)

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 582    Accepted Submission(s): 308


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
NO YES NO



#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define MAX 100010
struct node
{
	int x,y;
}point[MAX];
int map[1010][1010];
double dis[MAX];
double dist(node s1,node s2)
{
	double s=sqrt((1.0*s1.x-s2.x)*(s1.x-s2.x)+(s1.y-s2.y)*(s1.y-s2.y));
	return s;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		double minn=10000000;
		memset(dis,0,sizeof(dis));
		memset(map,0,sizeof(map));
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		scanf("%d%d",&point[i].x,&point[i].y);
		int cnt=0;
		for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
		{
			if(i==j) continue;
			if(!map[i][j])
			{
				dis[cnt]=dist(point[i],point[j]);
				if(minn>dis[cnt]&&dis[cnt]!=0) 
				minn=dis[cnt];
				cnt++;
				map[i][j]=1;
			}
		}
		int ans=0;
		for(int i=0;i<cnt;i++)
		if(minn==dis[i]) ans++;
		//printf("%d %d %d",ans,n,minn);
		if(ans==2*n)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}

posted @ 2015-12-06 14:18  上弦月307  阅读(219)  评论(0编辑  收藏  举报