hdoj--3552--I can do it!(贪心模拟)

I can do it!

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1022    Accepted Submission(s): 475



Problem Description
Given n elements, which have two properties, say Property A and Property B. For convenience, we use two integers Ai and Bi to measure the two properties.
Your task is, to partition the element into two sets, say Set A and Set B , which minimizes the value of max(x∈Set A) {Ax}+max(y∈Set B) {By}.
See sample test cases for further details.
 

Input
There are multiple test cases, the first line of input contains an integer denoting the number of test cases.
For each test case, the first line contains an integer N, indicates the number of elements. (1 <= N <= 100000)
For the next N lines, every line contains two integers Ai and Bi indicate the Property A and Property B of the ith element. (0 <= Ai, Bi <= 1000000000)
 

Output
For each test cases, output the minimum value.
 

Sample Input
1 3 1 100 2 100 3 1
 

Sample Output
Case 1: 3
 

Author
HyperHexagon
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:  3553 3545 3546 3547 3548


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
	int a,b;
}num[1000100];
int cmp(node s1,node s2)
{
	return s1.a>s2.a;
}
int main()
{
	int t,n;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		scanf("%d%d",&num[i].a,&num[i].b);
		int maxx1=0,ans=0x3f3f3f3f;
		sort(num+1,num+1+n,cmp);
		num[0].b=0;
		num[n+1].a=0;
		for(int i=1;i<=n+1;i++)
		{
			maxx1=max(maxx1,num[i-1].b);
			ans=min(ans,num[i].a+maxx1);
		}
		printf("Case %d: %d\n",k++,ans);
	}
	return 0;
}

 
posted @ 2015-12-20 17:05  上弦月307  阅读(189)  评论(0编辑  收藏  举报