hdoj--1018--Big Number(简单数学)

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32410    Accepted Submission(s): 15175


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2 10 20
 

Sample Output
7 19
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1013 1017 1071 1019 1021 

刚看题的时候没看数据范围,傻乎乎的用大数阶乘,后来才发现有规律啊!!
附上大数的,但是不会过
//#include<stdio.h>
//#include<string.h>
//int main()
//{
//	int t;
//	scanf("%d",&t);
//	int n,num[200];
//	while(t--)
//	{
//		memset(num,0,sizeof(num));
//		num[0]=1;
//		scanf("%d",&n);
//		int j;
//		int c=0;
//		for(int i=1;i<=n;i++)
//		{
//			for(j=0;j<=199;j++)
//			{
//				num[j]=num[j]*i+c;
//				if(num[j]>=10)
//				{
//					c=num[j]/10;
//					num[j]-=c*10;
//				}
//				else c=0;
//			}
//			
//		}
//		for(j=199;j>=0;j--)
//		if(num[j]!=0) 
//		break;
//		printf("%d\n",j+1);
//	}
//	return 0;
//} 
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		double ans=0;
		for(int i=1;i<=n;i++)
		ans+=log10(i);
		printf("%d\n",(int)ans+1);
	}
	return 0;
}


posted @ 2016-01-11 19:59  上弦月307  阅读(257)  评论(0编辑  收藏  举报