poj--1985--Cow Marathon(树的直径)

Cow Marathon
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 4424   Accepted: 2214
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

输的直径,先找到最长路径,然后以最长路径的端点开始找,第二次bfs找到树的直径

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
#define MAXN 50100
int head[MAXN],dis[MAXN],vis[MAXN];
int m,n,cnt,Node,ans;
struct node
{
	int u,v,val;
	int next;
}edge[MAXN*10];
void init()
{
	memset(head,-1,sizeof(head));
	cnt=0;
}
void add(int u,int v,int val)
{
	node E={u,v,val,head[u]};
	edge[cnt]=E;
	head[u]=cnt++;
}
void getmap()
{
	char op[2];
	int a,b,c;
	for(int i=0;i<m;i++)
	{
		scanf("%d%d%d%s",&a,&b,&c,op);
		add(a,b,c);
		add(b,a,c);
	}
}
void bfs(int sx)
{
	queue<int>q;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	ans=0;
	Node=sx;
	q.push(Node);
	vis[Node]=1;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			node E=edge[i];
			if(!vis[E.v])
			{
				vis[E.v]=1;
				dis[E.v]=dis[E.u]+E.val;
				q.push(E.v);
			}
		}
	}
	for(int i=1;i<=n;i++)
	{
		if(ans<dis[i])
		{
			ans=dis[i];
			Node=i;
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		getmap();
		bfs(1);
		bfs(Node);
		printf("%d\n",ans);
	}
	return 0;
}


posted @ 2016-01-12 18:20  上弦月307  阅读(183)  评论(0编辑  收藏  举报