hdoj--1258--Sum It Up(dfs)

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5534    Accepted Submission(s): 2890



Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 

Sample Output
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
 

Source
浙江工业大学第四届大学生程序设计竞赛

题意:从m个数中取若干个数,是的这若干个数的和为n,输出每一个方案
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int num[100],n,m,a[100];
int ans;
void dfs(int pre,int x,int r)
{
	if(pre==n)
	{
		ans++;
		printf("%d",a[0]);
		for(int i=1;i<r;i++)
		printf("+%d",a[i]);
		printf("\n");
	}
	else
	{
		for(int i=x;i<m;i++)  
	    {  
	        if(pre+num[i]<=n)  
	        {  
	            a[r]=num[i];  
	            dfs(pre+num[i],i+1,r+1);  
	            while(i+1<m&&num[i]==num[i+1])  //去重 
	            i++;  
	        }  
	    }  
	}
}
int cmp(int a,int b)
{
	return a>b;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(m==0&&n==0) break;
		memset(num,0,sizeof(num));
		memset(a,0,sizeof(a));
		for(int i=0;i<m;i++)
		scanf("%d",&num[i]);
		sort(num,num+m,cmp);
		printf("Sums of %d:\n",n);
		ans=0;
		dfs(0,0,0);
		if(ans==0)
		printf("NONE\n");
	}
	return 0;
}


posted @ 2016-02-06 14:21  上弦月307  阅读(178)  评论(0编辑  收藏  举报