poj--2516--Minimum Cost(最小费用流)

Minimum Cost
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 15340   Accepted: 5304

Description

Dearboy, a goods victualer, now comes to a big problem, and he needs your help. In his sale area there are N shopkeepers (marked from 1 to N) which stocks goods from him.Dearboy has M supply places (marked from 1 to M), each provides K different kinds of goods (marked from 1 to K). Once shopkeepers order goods, Dearboy should arrange which supply place provide how much amount of goods to shopkeepers to cut down the total cost of transport.

It's known that the cost to transport one unit goods for different kinds from different supply places to different shopkeepers may be different. Given each supply places' storage of K kinds of goods, N shopkeepers' order of K kinds of goods and the cost to transport goods for different kinds from different supply places to different shopkeepers, you should tell how to arrange the goods supply to minimize the total cost of transport.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, K (0 < N, M, K < 50), which are described above. The next N lines give the shopkeepers' orders, with each line containing K integers (there integers are belong to [0, 3]), which represents the amount of goods each shopkeeper needs. The next M lines give the supply places' storage, with each line containing K integers (there integers are also belong to [0, 3]), which represents the amount of goods stored in that supply place.

Then come K integer matrices (each with the size N * M), the integer (this integer is belong to (0, 100)) at the i-th row, j-th column in the k-th matrix represents the cost to transport one unit of k-th goods from the j-th supply place to the i-th shopkeeper.

The input is terminated with three "0"s. This test case should not be processed.

Output

For each test case, if Dearboy can satisfy all the needs of all the shopkeepers, print in one line an integer, which is the minimum cost; otherwise just output "-1".

Sample Input

1 3 3   
1 1 1
0 1 1
1 2 2
1 0 1
1 2 3
1 1 1
2 1 1

1 1 1
3
2
20

0 0 0

Sample Output

4
-1

Source

POJ Monthly--2005.07.31, Wang Yijie
送货问题,现在又n个店m个仓库k种商品,输入中有n*k的矩阵,表示每一位商家对每种商品的需求,然后是m*k的矩阵,表示每一个仓库中各种商品的储存量,最后是k个n*m的矩阵,n*m的矩阵中,i行j列表示第k种商品从j到i的花费,求最少的路费
建立超级源点跟超级汇点
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
#define MAXN 200
#define MAXM 10000+10
#define INF 0x3f3f3f3f
struct node
{
	int from,to,cap,flow,cost,next;
}edge[MAXM];
int head[MAXN],top,dis[MAXN],pre[MAXN];
bool vis[MAXN];
int source,sink;
int n,m,k;
int need[60][60];
int have[60][60];
int Sneed[60],Shave[60];
int used[60][60];
bool flag;
void init()
{
	top=0;
	memset(head,-1,sizeof(head));
}
void add(int a,int b,int w,int c)
{
	node E1={a,b,w,0,c,head[a]};
	edge[top]=E1;
	head[a]=top++;
	node E2={b,a,0,0,-c,head[b]};
	edge[top]=E2;
	head[b]=top++;
}
bool SPFA(int s,int t)
{
	queue<int>q;
	memset(dis,INF,sizeof(dis));
	memset(vis,false,sizeof(vis));
	memset(pre,-1,sizeof(pre));
	dis[s]=0;
	vis[s]=true;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			node E=edge[i];
			if(dis[E.to]>dis[u]+E.cost&&E.cap>E.flow)
			{
				dis[E.to]=dis[u]+E.cost;
				pre[E.to]=i;
				if(!vis[E.to])
				{
					vis[E.to]=true;
					q.push(E.to);
				}
			}
		}
	}
	return pre[t]!=-1;
}
int MCMF(int s,int t,int &cost,int &flow)
{
	cost=flow=0;
	while(SPFA(s,t))
	{
		int Min=INF;
		for(int i=pre[t];i!=-1;i=pre[edge[i^1].to])
		{
			node E=edge[i];
			Min=min(Min,E.cap-E.flow);
		}
		for(int i=pre[t];i!=-1;i=pre[edge[i^1].to])
		{
			edge[i].flow+=Min;
			edge[i^1].flow-=Min;
			cost+=edge[i].cost*Min;
		}
		flow+=Min;
	}
	return flow;
}
void solve()
{
	memset(Sneed,0,sizeof(Sneed));
	memset(Shave,0,sizeof(Shave));
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=k;j++)
		{
			scanf("%d",&need[i][j]);
			Sneed[j]+=need[i][j];
		}
	}
	for(int i=1;i<=m;i++)
	{
		for(int j=1;j<=k;j++)
		{
			scanf("%d",&have[i][j]);
			Shave[j]+=have[i][j];
		}
	}
	flag=true;
	for(int i=1;i<=k;i++)
	{
		if(Shave[i]<Sneed[i])
		{
			flag=false;
			break;
		}
	}
	int ans=0;
	int cost,flow;
	for(int j=1;j<=k;j++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int s=1;s<=m;s++)
			scanf("%d",&used[i][s]);
		}
		if(!flag) continue;
		init();
		source=0,sink=n+m+1;
		for(int i=1;i<=n;i++)
			add(i,sink,need[i][j],0);
		for(int i=1;i<=m;i++)
			add(source,i+n,have[i][j],0);
		for(int i=1;i<=m;i++)
		for(int s=1;s<=n;s++)
		add(i+n,s,INF,used[s][i]);
		MCMF(source,sink,cost,flow);
		if(flow!=Sneed[j])
			flag=false;
		else
			ans+=cost;
	}
	if(flag)
		printf("%d\n",ans);
	else
		printf("-1\n");
}
int main()
{
	while(scanf("%d%d%d",&n,&m,&k),m||m||k)
	{
		solve();
	}
	return 0;
}


posted @ 2016-02-12 17:24  上弦月307  阅读(307)  评论(0编辑  收藏  举报