poj--3061--Subsequence(贪心)

Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10882   Accepted: 4498

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006

简直就是超时专题,还是自己太傻了,想着暴力可以的,

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[100000+10];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,ans;
		scanf("%d%d",&n,&ans);
		memset(num,0,sizeof(num));
		for(int i=0;i<n;i++)
		scanf("%d",&num[i]);
		int l=0,r=0,minn=0x3f3f3f,sum=0;
		bool f=false;
		while(r<n)
		{
			sum+=num[r++];
			while(sum>=ans)
			{
				f=true;
				minn=min(minn,r-l);
				sum-=num[l++];
			}
		}
		if(f)
		printf("%d\n",minn);
		else
		printf("0\n");
	}
	return 0;
}


posted @ 2016-03-05 14:04  上弦月307  阅读(132)  评论(0编辑  收藏  举报