HDU3047 Zjnu Stadium

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2302    Accepted Submission(s): 876


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

 

Input
There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

 

Output
For every case: 
Output R, represents the number of incorrect request.
 

 

Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
 
Sample Output
2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)
 

 

Source
 
并查集....
当已经安排过的两个人 又被安排在不同的位置时 产生矛盾
/* ***********************************************
Author        :pk28
Created Time  :2015/8/15 15:11:05
File Name     :4.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 50000+10
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;

bool cmp(int a,int b){
    return a>b;
}
int n,m,ans;
int fa[maxn];
int d[maxn];
void init(){
    for(int i=1;i<=n;i++){
        fa[i]=i;
        d[i]=0;
    }
    ans=0;
}
int findfa(int x){
    if(x==fa[x]) return x;
    else{
        int root=findfa(fa[x]);
        d[x]+=d[fa[x]];
        fa[x]=root;
        return fa[x];
    }
}
void Union(int a,int b,int w){
    int x=findfa(a);
    int y=findfa(b);
    if(x==y){
        if(d[b]!=d[a]+w)ans++;//产生矛盾
        return ;
    }
    fa[y]=x;
    d[y]= d[a]+w-d[b];//向量
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int a,b,w;
    while(cin>>n>>m){
        init();
        for(int i=1;i<=m;i++){
            scanf("%d %d %d",&a,&b,&w);
            Union(a,b,w);
        }
        printf("%d\n",ans);
     }
    return 0;
}

######

 2015年12月19日更新

觉得加上这位同学画的图会更好理解些

 

posted on 2015-08-15 17:08  Beserious  阅读(158)  评论(0编辑  收藏  举报