Maven问题总结:Eclipse中项目右键菜单中点击Maven->Update Projects时JDK被重置

Eclipse中在项目右键菜单点击->Maven->Update Projects时,JDK总是切回 1.5

如果没有在Maven中配置过JDK版本,只是在Eclipse中项目的Properties配置里修改了Java版本,当运行Maven->Update Projects时,Java版本又会被切回默认的1.5。

编译器插件用来编译项目的源文件.从3.0版本开始, 用来编译Java源文件的默认编译器是javax.tools.JavaCompiler (如果你是用的是java 1.6) . 如果你想强制性的让插件使用javac,你必须配置插件选项 forceJavacCompilerUse. 

 同时需要注意的是目前source选项和target 选项的默认设置都是1.5, 与运行Maven时的JDK版本无关.如果你想要改变这些默认设置, 可以参考 Setting the -source and -target of the Java Compiler中的描述来设置 source 和target 选项.

运行Maven->Update Project时,会根据maven和pom.xml配置调用eclipse插件重建Eclipse工程文件(.project、.classpath和.settings)。因此Eclipse中的配置会被重置。

 

方式一: 可以修改项目的配置,指定编译使用的java版本。

如下配置pom.xml文件:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.6</source>
                <target>1.6</target>
                <encoding>UTF-8</encoding>
            </configuration>
        </plugin>
    </plugins>
</build>

 

方式二:配置Maven默认使用的JDK版本

%M2_HOME%/conf/settings.xml文件中加入如下配置:

<profiles>   
       <profile>     
            <id>jdk-1.6</id>     
            <activation>     
                <activeByDefault>true</activeByDefault>     
                <jdk>1.6</jdk>     
            </activation>     
            <properties>     
                <maven.compiler.source>1.6</maven.compiler.source>     
                <maven.compiler.target>1.6</maven.compiler.target>     
                <maven.compiler.compilerVersion>1.6</maven.compiler.compilerVersion>     
            </properties>     
    </profile>    
</profiles> 

本节参考文档:http://my.oschina.net/jackieyeah/blog/223792

 

posted @ 2015-11-19 14:44  XRacoon  阅读(2194)  评论(0编辑  收藏  举报