多个php版本的composer使用

由于系统环境变量之前同事安装的laravel是5.1...php默认的环境变量是:

不想破话原有环境变量,因为现在新的项目是laravel5.4.。。所以在用默认composer require安装时提示php版本过低滴问题
问题是这样滴:

 

默认composer安装会调用原来的php5.5环境变量,所以这里安装会出现兼容问题
新项目使用的是php7.1

那么如何在多个php版本中互不干扰安装composer呢,折腾了半个多小时,
现在说下解决办法吧:

1:下载composer.phar,官网有直接下载的链接,https://getcomposer.org/download/
2:composer.phar 复制到项目根目录,比如我的是:/home/www/web
3:执行 /usr/local/php7/bin/php composer.phar update (这里我的安装路径是/usr/local/php7/bin/php,不一定适合你额,请对号入座即可吧)
4:安装依赖包:/usr/local/php7/bin/php composer.phar require laravel/scout

  

OK,大功告成!

 

无论从事什么行业,只要做好两件事就够了,一个是你的专业、一个是你的人品,专业决定了你的存在,人品决定了你的人脉,剩下的就是坚持,用善良專業和真诚赢取更多的信任。
posted @ 2017-05-02 13:31  周伯通的麦田  阅读(20003)  评论(0编辑  收藏  举报