The openssl extension is required for SSL/TLS protection but is not available

今天使用composer update发现报错:The openssl extension is required for SSL/TLS protection but is not available
网上很多人说开启“extension = php_openssl.dll”,事实上我的已经是开启的,错误依旧提示。废话不说了

本地开发,我是关闭Composer的TLS来修复,注意:它不安全

composer config -g -- disable-tls true

同时开启php.ini中的

extension=openssl

特别提醒:

如果设置为true,则将使用HTTP尝试所有HTTPS URL,而不执行网络级加密。启用这是一个安全风险,不推荐。更好的方法是在php.ini中启用php_openssl和openssl扩展。

附最终结果图:

 

无论从事什么行业,只要做好两件事就够了,一个是你的专业、一个是你的人品,专业决定了你的存在,人品决定了你的人脉,剩下的就是坚持,用善良專業和真诚赢取更多的信任。
posted @ 2019-01-17 16:22  周伯通的麦田  阅读(6476)  评论(0编辑  收藏  举报