centos 卸载python和yum之后的解决办法

网上看到有同学yum不能使用的消息,出现了下面的结果

 

无赖的使用了网上的很多方法,还是不行。

于是我卸载了python和yum,觉得自己重新安装python和yum。

步骤1:卸载python

rpm -qa|grep python|xargs rpm -e --allmatches --nodeps

whereis python|xargs rm -fr

步骤2:卸载yum

rpm -qa|grep yum|xargs rpm -e --allmatches --nodeps

rm -rf /etc/yum.repos.d/*

whereis yum|xargs rm -fr

步骤3:安装python

在任何一个镜像站中找到你系统对应版本的python rpm包(我的是centos 6.9的64位系统,使用的镜像是http://mirrors.163.com/centos/6.9/os/x86_64/Packages/)

mkdir /usr/local/src/python

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/python-2.6.6-66.el6_8.x86_64.rpm

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/python-iniparse-0.3.1-2.1.el6.noarch.rpm

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/python-pycurl-7.19.0-9.el6.x86_64.rpm

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/python-devel-2.6.6-66.el6_8.x86_64.rpm

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/python-libs-2.6.6-66.el6_8.x86_64.rpm

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/python-urlgrabber-3.9.1-11.el6.noarch.rpm

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/rpm-python-4.8.0-55.el6.x86_64.rpm

 

切换到/usr/local/src/python路径下

rpm -ivh python-*   rpm-python-* 

如果中间过程出现了类似下面的代码,这是包与包之间的依赖关系,只需要卸载已经安装的包(rpm -e 包名(没有.rpm后缀)),然后先安装依赖包

如:

      rpm -e yum-metadata-parser-1.1.2-16.el6.x86_64

       rpm -ivh /yum-metadata-parser-1.1.2-16.el6.x86_64.rpm

步骤4:安装yum

mkdir /usr/local/src/yum

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/yum-3.2.29-81.el6.centos.noarch.rpm  

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/yum-metadata-parser-1.1.2-16.el6.x86_64.rpm  

wget http://mirrors.163.com/centos/6.9/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.30-40.el6.noarch.rpm

切换到/usr/local/src/python路径下

rpm -ivh yum-*

步骤5:测试

运行

yum

(成功)

 

 

posted @ 2017-06-22 17:57  风雪之殇  阅读(31500)  评论(1编辑  收藏