AmazingCounters.com

BZOJ 3850: ZCC Loves Codefires【贪心】

Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".

It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.

But why?

Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.

After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.

What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.

Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).

 

Input

The first line contains an integer N(1≤N≤10^5), the number of problem in the round.

The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.

The last line contains N integers Ki(1≤Ki≤10^4), as was described.

 

Output

One integer L, the minimal score he will lose.

 

Sample Input

3
10 10 20
1 2 3

Sample Output

150

HINT

Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second.

L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.

题目大意:CF赛制的做题,有n道题,做每道题神犇需要Ei的时间将它AC,每道题每单位时间掉Ki分,问一个做题顺序使得掉分最少

思路:大水题,按Ei/Ki排个序的顺序进行做题即可

证明:假设数列{Ei}{Ki}为满足题意的最优序列,显然交换序列中两个相邻题目的顺序不会对其它题目产生影响

设∑Ej(0<j<=i-1)=u

则当前序列优于交换后的序列可以列出下列等式:

(u+Ei)*Ki+[u+Ei+E(i+1)]*K(i+1)<[u+E(i+1)]*K(i+1)+[u+Ei+E(i+1)]*Ki

化简上式即可得到:Ei/Ki<E(i+1)/K(i+1)

 

#include<cstdio>

#include<iostream>

#include<string>

#include<algorithm>

#define maxn 10000

using namespace std;

struct T{int x;int y;double sor;}a[maxn];

int cmp(T a,T b){return a.sor<b.sor;}

int main()

{

    int n,ans=0,u=0;scanf("%d",&n);

    for(int i=1;i<=n;i++)scanf("%d",&a[i].x);

    for(int i=1;i<=n;i++)scanf("%d",&a[i].y),a[i].sor=1.0*a[i].x/a[i].y;

    sort(a+1,a+1+n,cmp);

    for(int i=1;i<=n;i++)u+=a[i].x,ans+=u*a[i].y;

    printf("%d\n",ans);

    return 0;

}

posted @ 2015-01-07 16:13  philippica  阅读(212)  评论(0编辑  收藏  举报