HDOJ_1087_Super Jumping! Jumping! Jumping!

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow: N value_1 value_2 …value_N It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3


题解:这道题和前面拿到木根的差不多,核心思想都在于如何找到最大的那条路径并且还要把路径找全;核心代码关键在于两层循环;第一层循环就是从2遍历到n,
而地二层循环,则是往前遍历,不断地比较找到最大的那条路径。
AC代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define Max 1010
using namespace std;

long long a[Max];
long long dp[Max];
long long mmax;

int main(void)
{
    freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        
        dp[1]=a[1],mmax=a[1];
        for(int i=2;i<=n;i++)
        {
            dp[i]=a[i];
            for(int j=i-1;j>=1;j--)
            {
                if(!(a[i]>a[j]))
                    continue;
                    
                if(dp[i]<dp[j]+a[i])
                    dp[i]=dp[j]+a[i];
            }
            
        if(mmax<dp[i])    
            mmax=dp[i];
        }
        printf("%lld\n",mmax);
        
    }
    
    
    
    fclose(stdin);
    return 0;
}

 

posted @ 2018-12-16 05:57  pha创噬  阅读(109)  评论(0编辑  收藏  举报