轩辕

运筹帷幄世界在我手中!

导航

杭电 1008

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3418    Accepted Submission(s): 1762


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
1 2
3 2 3 1
0
 

Sample Output
17
41
 代码1:
#include<iostream>
using naemspace std;
int main()
{
int n,i,j,sum=0,str[100]={0};
cin>>n;
while(n!=0)
{
 for(i=1;i<=n;i++)
  cin>>str[i];
 sum+=n*5;
 for(i=0;i<n;i++)
  if(str[i+1]>str[i])
   sum+=(str[i+1]-str[i])*6;
  else
   sum+=(str[i]-str[i+1])*4;
  cout<<sum<<endl;
  sum=0;
  cin>>n;
}
return 0;
}

 代码2:

#include<stdio.h>
main()
{
 int n,r,t,l;
 while(scanf("%d",&n)==1&&n!=0)
 {
  r=0;l=0;
  while(n--!=0)
  {
   scanf("%d",&t);
  if(t>=l)
  {
   r+=(t-l)*6;
  }
 else
 { r+=(l-t)*4;
 }
 r+=5;
 l=t;
}
printf("%d\n",r);
}
return 0;
}

posted on 2011-08-18 16:33  峻华  阅读(240)  评论(0编辑  收藏  举报