pangqianjin

导航

安装@vue/cli报错,npm ERR! gyp ERR! not ok

执行npm install -g @vue/cli来安装vue3的cli时,出现了这个错误(太长了,具体执行到npm install joi时开始报错):

npm ERR! gyp ERR! not ok

我本身配置的是淘宝的镜像源,但是还是安装失败了,也试过用梯子+官方仓库,还是不行,
最后使用了淘宝的cnpm安装成功了,

npm install -g cnpm --registry=https://registry.npm.taobao.org
cnpm install -g @vue/cli

安装成功!

posted on 2021-06-25 15:54  pangqianjin  阅读(1278)  评论(0编辑  收藏  举报