Python3+RIDE+Robot Framework自动化测试框架搭建

Python2.7已于2020年1月1日开始停用,之前RF做自动化都是基于Python2的版本。

没办法,跟随时代的脚步,我们也不得不升级以应用新的控件与功能。

升级麻烦,直接全新安装。

一、Python安装

最新版Python下载地址:https://www.python.org/

根据操作系统选择对应版本制品下载安装即可,本机用的是Windows x86-64 executable installer。

注意事项:

安装完成后检查下环境变量,默认会配置好,可以检查下。

检测是否安装成功,可在CMD命令窗口输入python试一下,成功的话会显示Python的版本信息。

二、RobotFramework安装

RF测试框架。

安装方法:

CMD命令窗口运行pip命令:

pip install robotframework

三. WxPython安装

Wxpython是python非常有名的一个GUI库,RIDE就是基于这个库开发的。

安装方法:

pip install wxPython

四、RIDE安装

RIDE是一个图形界面工具,用于创建、组织、运行测试案例。

安装方法:

pip install robotframework-ride

安装过程中会提示是否创建桌面快捷方式,选择是,安装完成后,双击桌面“ride.exe”即可打开。

五、Selenium2library安装

RF的selenium库,借助Selenium,可以模拟浏览器端的测试,通常用于Web自动化测试。

Selenium测试可以在Windows、Linux上的 IE、Chrome和Firefox中运行。

安装方法:

pip install robotframework-selenium2library

六、Requets和HttpLibrary安装

RF的Requets库,Requests是Python的HTTP客户端库,可以通过调用request库发送GET、POST、PUT、DELETE请求。

HttpLibrary当然也可以了。都可以应用到接口自动化中。

安装方法:

pip install robotframework-requests
pip install robotframework-httplibrary(添加library时用HttpLibrary.HTTP)
#遇HttpLibrary.HTTP加载报错,参考Python3》导入HttpLibrary.HTTP报错解决方法

其它常用的测试库:按需安装

1)基于AppIum进行APP测试的库:

pip install robotframework-appiumlibrary

2)基于数据驱动进行测试的库:

pip install robotframework-databaselibrary(链接数据库)

pip install cx_Oracle(操作Oralce数据库)

pip install PyMySQL(操作Mysql数据库)

pip install openpyxl(操作EXCEL)

pip list【可检查安装测试库列表

七、运行测试

1)New Project,名字可自定义(type:Directoy;Format:ROBOT)

  • 若选择Directoy,目录下面可以新增Suite,Suite下可新增CASE
  • 若选择FILE,目录下只能创建CASE

2)  New Suite,名字可自定义,可配置CASE中使用的关键字。(type:File;Format:ROBOT)

  • 若选择Directoy,目录下还可以创建suite
  • 若选择FILE,目录下只能创建CASE

3)  New Test Case》名称可自定义,用例设计主要在这里。

一组相关的测试用例(Test Case)就是一个测试套件(Test Suite)。

也就是说,一个测试套件由多个测试用例串连组成,可以将测试套件理解为测试用例组。

这里写了一个简单的DEMO,来验证RIDE环境正常:

实例中声明一个变量${time},调用关键字GET TIME 来获取当前时间,使用log关键字,输出变量值,日常调试时会经常用到此方法。

  • Edit标签页:

  • Text Edit标签页:

与Edit页信息同步,都可以编辑测试用例,看个人习惯。

  • RUN标签页:

查看运行结果:提供Report和Log两种报告,展示的信息不一样,可按需查看。

Run标签页主要记录信息:

1)展示执行用例数,通过数、失败数,运行时间等信息

2)展示报告路径

3)展示case执行记录

 

 

八、FAQ

1、pip命令在python命令窗口下执行报错:SyntaxError: invalid syntax

解决方法:pip命令要在CMD命令窗口下执行

2、执行pinp时提示pip版本较低

解决方法:在CMD命令窗口下执python.exe -m pip install --upgrade pip更新到最新版即可。

3、RIDE启动没反应【找了N久才解决】

 解决方法:D:\python\Lib\site-packages\robotide\application\application.py这个文件里加上这句话

self.locale = wx.Locale(wx.LANGUAGE_ENGLISH)

4、RIED启动后Case下Edit为空

解决方法:据说是Python3.8不兼容RIDE,重装了Python3.7.5版本,可以了。

 


 

其它测试库或者问题欢迎大家补充完善。

后续会基于RF介绍如何实现API和UI自动化。

 

posted @ 2020-09-22 18:30  拜托拜托  阅读(393)  评论(0编辑  收藏  举报