hdu 5459 Jesus Is Here (费波纳茨递推)

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/102400 K (Java/Others)
Total Submission(s): 250    Accepted Submission(s): 169


Problem Description
I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?
``But Jesus is here!" the priest intoned. ``Show me your messages."
Fine, the first message is s1=c" and the second one is s2=ff".
The i-th message is si=si2+si1 afterwards. Let me give you some examples.
s3=cff"s4=ffcff" and s5=cffffcff".

``I found the i-th message's utterly charming," Jesus said.
``Look at the fifth message". s5=cffffcff" and two cff" appear in it.
The distance between the first cff" and the second one we said, is 5.
``You are right, my friend," Jesus said. ``Love is patient, love is kind.
It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.
Love does not delight in evil but rejoices with the truth.
It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different cff" as substrings of the message.
 

 

Input
An integer T (1T100), indicating there are T test cases.
Following T lines, each line contain an integer n (3n201314), as the identifier of message.
 

 

Output
The output contains exactly T lines.
Each line contains an integer equaling to:
i<j:sn[i..i+2]=sn[j..j+2]=cff"(ji) mod 530600414,

where sn as a string corresponding to the n-th message.
 

 

Sample Input
9
5
6
7
8
113
1205
199312
199401
201314
 

 

Sample Output
Case #1: 5
Case #2: 16
Case #3: 88
Case #4: 352
Case #5: 318505405
Case #6: 391786781
Case #7: 133875314
Case #8: 83347132
Case #9: 16520782
 

 

Source
 

题意s[i] = s[i-1] + s[i-2], s[1] = c, s[2] = ff;

s[i]中没两个c之间的距离之和

定义:dp[i]表示i所对应的答案, 那么dp[i] = dp[i-1] + dp[i-2] + (s[i-1]中的每个cs[i-2]中的c的距离)

定义:rd[i]表示s[i]中的每个cs[i]的末尾的距离

ld[i]表示s[i]中的每个cs[i]的首位的距离

ls[i]表示s[i]的长度

cnt[i]表示s[i]c的个数

那么有:

rd[i] = rd[i-1] + rd[i-2] + cnt[i-2] * ls[i-1];

ld[i] = ld[i-1] + ld[i-2] + cnt[i-1] * ls[i-2];

 

  dp[i] = dp[i-1] + dp[i-2] + cnt[i-1] * rd[i-2] + cnt[i-2] * ld[i-1];

dp[i] = dp[i-1] + dp[i-2] + cnt[i-1] * rd[i-2] + cnt[i-2] * ld[i-1];

 

#include <bits/stdc++.h>
using namespace std;

const int N = 201413;
const int M = 530600414;
typedef long long ll;

ll dp[N], rd[N], ld[N];
ll ls[N], cnt[N];

void init()
{
    ls[3] = 3; cnt[3] = 1; dp[3] = 0;
    ls[4] = 5; cnt[4] = 1; dp[4] = 0;
    rd[3] = 3; ld[3] = 0;
    rd[4] = 3; ld[4] = 2;
    for(int i = 5; i < N; ++i)
    {
        ls[i] = (ls[i - 1] + ls[i - 2]) % M;
        cnt[i] = (cnt[i - 1] + cnt[i - 2]) % M;

        rd[i] = (rd[i - 2] + rd[i - 1] + cnt[i - 2] * ls[i - 1]) % M;
        ld[i] = (ld[i - 2] + ld[i - 1] + cnt[i - 1] * ls[i - 2]) % M;

        dp[i] = (dp[i - 1] + dp[i - 2] + cnt[i - 1] * rd[i - 2] + cnt[i - 2] * ld[i - 1]) % M;
    }
}

int main()
{
    int _, cas = 1; scanf("%d", &_);
    init();
    while(_ --)
    {
        int n; scanf("%d", &n);
        printf("Case #%d: %lld\n",cas++, dp[n] % M);
    }
    return 0;
}

 

  

 

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/102400 K (Java/Others)
Total Submission(s): 250    Accepted Submission(s): 169


Problem Description
I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?
``But Jesus is here!" the priest intoned. ``Show me your messages."
Fine, the first message is s1=c" and the second one is s2=ff".
The i-th message is si=si2+si1 afterwards. Let me give you some examples.
s3=cff"s4=ffcff" and s5=cffffcff".

``I found the i-th message's utterly charming," Jesus said.
``Look at the fifth message". s5=cffffcff" and two cff" appear in it.
The distance between the first cff" and the second one we said, is 5.
``You are right, my friend," Jesus said. ``Love is patient, love is kind.
It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.
Love does not delight in evil but rejoices with the truth.
It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different cff" as substrings of the message.
 

 

Input
An integer T (1T100), indicating there are T test cases.
Following T lines, each line contain an integer n (3n201314), as the identifier of message.
 

 

Output
The output contains exactly T lines.
Each line contains an integer equaling to:
i<j:sn[i..i+2]=sn[j..j+2]=cff"(ji) mod 530600414,

where sn as a string corresponding to the n-th message.
 

 

Sample Input
9 5 6 7 8 113 1205 199312 199401 201314
 

 

Sample Output
Case #1: 5 Case #2: 16 Case #3: 88 Case #4: 352 Case #5: 318505405 Case #6: 391786781 Case #7: 133875314 Case #8: 83347132 Case #9: 16520782
 

 

Source
 
posted @ 2015-09-21 12:58  JL_Zhou  阅读(186)  评论(0编辑  收藏  举报