hdu 1069 Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8991    Accepted Submission(s): 4650


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

 

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 

 

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
 

 

Source
 
思路:又是DAG模型,由于每个长方体摆放情况只有3!种,先预处理出邻接表,dp[i]表示从节点i出发经过的路径中所能达到的最大值(二元组关系用图建模)
dp[i] = max{ dp[j] + zi } 其中j是i的邻接点,zi为节点i的高
time : 0 ms
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <queue>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
using namespace std ;
struct tri
{
    int x ;
    int y ;
    int z ;
} r[200] ;
int dp[200];
int n, m, c = 1 ;
vector<int> G[200] ;
void _in()
{
    for(int i = 0; i < 200; ++i)
    G[i].clear() ;
    int a[3] ;
    for(int i = 1 ; i <= 6 * n; i += 6)
    {
        scanf("%d%d%d",&a[0],&a[1],&a[2]) ;
        sort(a,a + 3) ;
        for(int j = i; j < 6 + i; ++j)
        {
            r[j].x = a[0] ;
            r[j].y = a[1] ;
            r[j].z = a[2] ;
            next_permutation(a,a + 3) ;
        }
    }
    m = 6 * n ;
    for(int i = 1; i <=m; ++i)
        for(int j =1; j <= m; ++j)
        {
            if(r[i].x > r[j].x && r[i].y > r[j].y) {
                G[i].push_back(j) ;
            }
        }
}
    int getans(int t)
    {
        int& ans = dp[t] ;
        if(ans != -1) return ans ;
        int s = G[t].size() ;
        ans = 0 ;
        for(int i = 0; i < s; ++i)
        {
            ans = max(ans,getans(G[t][i]) + r[G[t][i]].z) ;
        }
        return ans ;
    }
    int main()
    {
        //freopen("in.txt","r",stdin) ;
        while(~scanf("%d",&n))
        {
            if(!n) break ;
            memset(dp, -1, sizeof dp) ;
            _in() ;
            int res = 0 ;
            for(int i = 1; i <= m ; ++i)
            {
                res = max(res, getans(i) + r[i].z) ;
            }
            printf("Case %d: maximum height = %d\n",c++, res) ;
        }
        return 0 ;
    }
View Code

 

posted @ 2015-05-15 10:29  JL_Zhou  阅读(140)  评论(0编辑  收藏  举报