A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13724    Accepted Submission(s): 5239


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

 

Sample Input
5 1 5
3 3 1 2 5
0
 

 

Sample Output
3
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int N,A,B;
int flor[250];
int dir[]={-1,1};//上下方向
struct node{
    int x;//楼层
    int step_cnt;//步数
};
node now,nextf;
node vs,vd;//起点和终点
int leap;
int vis[250];//标记数组只需一维,即标记刚入队的nextf,下次不用再回到此处,
            //因你到了nextf结点后,只会有上下两个选择,即使下次再回到此处
            //面对的仍是上下两个选择,而在第一次就可抉择
void in_put()
{
    scanf("%d%d",&A,&B);
    for(int i=1;i<=N;++i)
        scanf("%d",&flor[i]);
        vs.x=A;
        vd.x=B;
}
void bfs()
{
    queue<node>Q;
    vs.step_cnt=0;
    Q.push(vs);
    while(!Q.empty()){
        now=Q.front();
         Q.pop();
        if(now.x==vd.x) {leap=1;return;}
        for(int i=0;i<2;++i){
            nextf.x=now.x+dir[i]*flor[now.x];
            nextf.step_cnt=now.step_cnt+1;
        if(nextf.x>=1&&nextf.x<=N&&!vis[nextf.x]) {Q.push(nextf);vis[nextf.x]=1;}//迷之wa,原因在于写出了vis[now.x]=1;
        }
    }
}
int main()
{
    while(scanf("%d",&N)&&N){
        leap=0;
         memset(vis,0,sizeof(vis));
        in_put();
        bfs();
        if(leap)
        printf("%d\n",now.step_cnt);
        else printf("-1\n");
    }
}

 

posted @ 2015-03-26 19:39  JL_Zhou  阅读(170)  评论(0编辑  收藏  举报