linux下VMware安装出现的问题解决

linux下VMware安装出现的问题解决

本文由乌合之众 lym瞎编,欢迎转载 blog.cnblogs.net/oloroso
本文由乌合之众 lym瞎编,欢迎转载 my.oschina.net/oloroso

系统环境 ubuntu-kylin 15.04

o@o-pc:~/software$ uname -a
Linux o-pc 3.19.0-22-generic #22-Ubuntu SMP Tue Jun 16 17:15:15 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

报错信息

Gtk-Message: Failed to load module "overlay-scrollbar": liboverlay-scrollbar.so: 无法打开共享对象文件: 没有那个文件或目录
Gtk-Message: Failed to load module "unity-gtk-module": libunity-gtk-module.so: 无法打开共享对象文件: 没有那个文件或目录

(vmware-installer.py:1593): Gtk-WARNING **: 无法在模块路径中找到主题引擎:“murrine”,

...

(vmware-installer.py:1593): Gtk-WARNING **: 无法在模块路径中找到主题引擎:“murrine”,
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: 无法打开共享对象文件: 没有那个文件或目录

问题1liboverlay-scrollbar.solibunity-gtk-module.so加载失败的问题。

这个问题的解决很简单,我们先看报错的信息。这里提示的是Gtk-Message,是Gtk的一个消息罢了,解决的办法就是使用sudo来运行安装程序,这个错误就会消失啦。原因是权限的问题。

o@o-pc:~/software$ sudo ./VMware-Workstation-Full-11.1.2-2780323.x86_64.bundle 
Extracting VMware Installer...done.

(vmware-installer.py:6469): Gtk-WARNING **: 无法在模块路径中找到主题引擎:“murrine”,
...
(vmware-installer.py:6469): Gtk-WARNING **: 无法在模块路径中找到主题引擎:“murrine”,
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: 无法打开共享对象文件: 没有那个文件或目录

问题2 Gtk-WARNING **: 无法在模块路径中找到主题引擎:“murrine”

这个错误的原因,应该是没有安装gtk2-engines-murrine,那么就安装一下咯。

 sudo apt-get install gtk2-engines-murrine 

问题3 无法加载libcanberra-gtk-module.so的问题

先来找一下这个libcanberra-gtk-module.so

o@o-pc:~/software$ locate libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.so

找到了两个,那么使用哪一个呢?不管它,两个都加入到系统的动态库加载配置中。


  • 先创建两个文件:
    sudo touch /etc/ld.so.conf.d/gtk-2.0.conf
    sudo touch /etc/ld.so.conf.d/gtk-3.0.conf
  • .so的路径加入到这两个文件中。
    使用vim打开,注意权限。
    sudo vim /etc/ld.so.conf.d/gtk-2.0.conf
    然后插入之前搜索到的路径
    /usr/lib/x86_64-linux-gnu/gtk-2.0/modules
    对于另一个文件,就加入另一个路径了。这里就不说了。其实只要有这一个就够用了。
  • 使用ldconfig重新加载下,要注意权限哦。
    sudo ldconfig
  • 重新运行sudo ./VMware-Workstation-Full-11.1.2-2780323.x86_64.bundle

如果机器上没有libcanberra-gtk-module.so这个问题怎么办呢?
这还不简单,安装就是咯。

sudo apt-get install libcanberra*

这条命令会安装很多多余的东西。应该只要安装libcanberra0libcanberra-gtk-modulelibcanberra-gtk3-module就可以了吧。

posted @ 2015-07-01 12:36  乌合之众  阅读(11616)  评论(0编辑  收藏  举报