会员
周边
新闻
博问
闪存
赞助商
Chat2DB
所有博客
当前博客
我的博客
我的园子
账号设置
会员中心
简洁模式
...
退出登录
注册
登录
牛奔
每个优秀的人,都有一段沉默的时光,那段时光,是付出了很多努力,却得不到结果的日子,我们把它叫做扎根。
博客园
首页
新随笔
联系
订阅
管理
上一页
1
···
13
14
15
16
17
18
19
20
21
···
95
下一页
2024年4月25日
docker配置Nvidia环境,使用GPU
摘要: 前言 需要 nvdia driver 安装好,请参考 Ubuntu Nvidia driver驱动安装及卸载 docker 安装 配置 apt 阿里云的镜像源 sudo curl -fsSL https://mirrors.aliyun.com/docker-ce/linux/ubuntu/gpg
阅读全文
posted @ 2024-04-25 09:03 牛奔
阅读(4619)
评论(0)
推荐(0)
2024年4月23日
Ubuntu Nvidia driver驱动安装及卸载
摘要: 前言 当前英伟达下载的驱动不再是 .run 的 shell文件,所以有了新的文档,如下 Ubuntu Nvidia driver驱动安装(新) 当然如果你有 shell 文件,也可以继续使用本文档安装驱动 下载官方驱动安装 1.安装驱动前一定要更新软件列表和安装必要软件、依赖(必须) sudo ap
阅读全文
posted @ 2024-04-23 09:46 牛奔
阅读(11685)
评论(0)
推荐(0)
2024年4月22日
k8s node节点报错 dial tcp 127.0.0.1:8080: connect: connection refused
摘要: 前言 在搭建好 kubernetes 环境后,master 节点拥有 control-plane 权限,可以正常使用 kubectl。 但其他 node 节点无法使用 kubectl 命令,即使同步过去 /root/.kube/config 文件到各个 node 节点上,也不行。 解决 检查 KUB
阅读全文
posted @ 2024-04-22 14:22 牛奔
阅读(1424)
评论(0)
推荐(0)
calico配置报错 kubelet.go:2855] "Container runtime network not ready"
摘要: 前言 配置 calico 网络插件时,kubectl get node 报错: NoReady kubectl describe node node Name: node Roles: <none> Labels: beta.kubernetes.io/arch=amd64 beta.kuberne
阅读全文
posted @ 2024-04-22 13:57 牛奔
阅读(803)
评论(0)
推荐(0)
2024年4月17日
Linux ab详解
摘要: 前言 ab是apachebench命令的缩写,ab是apache自带的压力测试工具。ab非常实用,它不仅可以对apache服务器进行网站访问压力测试,也可以对或其它类型的服务器进行压力测试。比如nginx、tomcat、IIS等。 ab的原理:ab命令会创建多个并发访问线程,模拟多个访问者同时对某一
阅读全文
posted @ 2024-04-17 09:38 牛奔
阅读(671)
评论(0)
推荐(0)
2024年4月8日
Kubernetes 编译 kubeadm 修改证书有效期到 100 年
摘要: 前言 kubeadm 生成的客户端证书在 1 年后到期。过期后,会导致服务不可用,使用过程中会出现:x509: certificate has expired or is not yet valid. 默认情况下,kubeadm 会生成运行一个集群所需的全部证书。但要使用自定义的证书,需要生成各个组
阅读全文
posted @ 2024-04-08 09:13 牛奔
阅读(1237)
评论(0)
推荐(0)
2024年3月28日
k8s v1.19版本之后,自签证书过期x509: certificate has expired or is not yet valid
摘要: 前言 在 Kubernetes 1.16 版本之前,kubeadm 工具的 alpha certs 子命令用于生成和管理 Kubernetes 集群的证书。然而,从 Kubernetes 1.19 版本开始,kubeadm 引入了一套新的证书管理 API,并移除了 alpha certs 子命令。
阅读全文
posted @ 2024-03-28 09:58 牛奔
阅读(626)
评论(0)
推荐(0)
2024年3月27日
k8s v1.16.3,Unable to connect to the server: x509: certificate has expired or is not yet valid
摘要: 前言 kubernetes 版本为 v1.16.3 使用 kubelet get node 后报错: x509: certificate has expired or is not yet valid ,提示证书过期。 解决 检查证书何时过期 kubeadm alpha certs check-ex
阅读全文
posted @ 2024-03-27 18:59 牛奔
阅读(944)
评论(0)
推荐(0)
2024年3月26日
MySQL超大表删除数据过程
摘要: 背景 笔者在公司负责公司的OpenAPI应用,估产生了调用审计的需求。对于存储这些AccessLog,虽然业界有很合适的架构和理论,奈何我司已成本优先,且作为toB的项目,调用量并不算特别大,每天也就2G左右的AccessLog产生。业务特征又导致整个订单的周期非常长,最少要保存1年以上的记录,以备
阅读全文
posted @ 2024-03-26 22:50 牛奔
阅读(129)
评论(0)
推荐(0)
2024年3月22日
helm常用命令
摘要: helm常用命令 helm repo update # 确定我们可以拿到最新的charts列表 helm show chart bitnami/mysql # 命令简单的了解到这个chart的基本信息 helm show all bitnami/mysql # 获取关于该chart的所有信息。 he
阅读全文
posted @ 2024-03-22 22:48 牛奔
阅读(1450)
评论(0)
推荐(0)
上一页
1
···
13
14
15
16
17
18
19
20
21
···
95
下一页
公告