ZOJ 3777 Problem Arrangement(DP)



ZOJ Problem Set - 3777
Problem Arrangement

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to Mpoints, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output

3/1
No solution

Author: DAI, Longao
Source: The 11th Zhejiang Provincial Collegiate Programming Contest



很明显状态压缩可心搞

dp[x][y][z]到前x行列状态为y和为z的排列数

dp[x+1][y|(1<<k)][z+f[x][j]] += dp[x][y][z]

优化,一行肯定要选定一个数,所以当状态中数和之前不符合就可以不算了。


#include <iostream>
#include <cstdio>
#include <cstring>
#define ll(x) (1<<x)
#define clr(f,z) memset(f,z,sizeof(f))
#define LL long long
using namespace std;
const int mm = 13;
int f[mm][mm];
LL dp[ll(mm)][502];
int bit[ll(mm)];
int n,m;
int lowbit(int x)
{
    return x&(x-1);
}
void debug()
{
    puts("_______________---");
    int z = ll(n)-1;
    for(int i=0;i<=z;++i)
    for(int j=0;j<m;++j)
        printf("%d%c",dp[i][j],'-');
    puts("-------------------");
}
LL DP()
{
  //clr(dp,0);

  int z = ll(n)-1;
  for(int i=0;i<=z;++i)
    for(int j=0;j<m;++j)
    dp[i][j] = 0;
   // debug();
  dp[0][0] = 1;
  bit[0] = 0;
  for(int i=1;i<=z;++i)
    bit[i] = bit[lowbit(i)]+1;
  for(int t=0;t<n;++t)
  {
      if(t == 0)
      {
        for(int i=0;i<n;++i)
            dp[ll(i)][f[0][i]] += dp[0][0];
      }
      else
      {
        for(int i=z;i>=1;--i)
        {
            if(bit[i] != t)
                continue;
            for(int j=m-1;j>=0;--j)
            for(int k=0;k<n;++k)
            if(dp[i][j] && (i&ll(k)) == 0 && j+f[t][k]<m)
            dp[i|ll(k)][j+f[t][k]] += dp[i][j];
        }
      }
  }
 // debug();
  LL ans = 0;
  for(int i=0;i<m;++i)
    ans += dp[z][i];
  return ans;
}
LL gcd(LL x,LL y)
{
    while(x!=0)
    {
        LL z = x;
        x = y % x;
        y = z;
    }
    return y;
}
int main()
{
    int cas;
    while(~scanf("%d",&cas))
    {
        while(cas--)
        {
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;++i)
                for(int j=0;j<n;++j)
                    scanf("%d",&f[i][j]);
            LL num = DP();
            //cout<<"g"<<num<<endl;
            LL all = 1;
            for(int i=1;i<=n;++i)
                all *= i;
            num = all - num;
            LL g = gcd(num,all);

            all /= g;
            num /= g;
            if(num == 0)
                puts("No solution");
            else printf("%lld/%lld\n",all,num);
        }
    }
    return 0;
}


ZOJ Problem Set - 3777
Problem Arrangement

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to Mpoints, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output

3/1
No solution

Author: DAI, Longao
Source: The 11th Zhejiang Provincial Collegiate Programming Contest
posted @ 2014-05-08 16:27  剑不飞  阅读(178)  评论(0编辑  收藏  举报