HDU 3535 AreYouBusy(多重背包模板)

AreYouBusy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4604 Accepted Submission(s): 1884

Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What’s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as “jobs”. A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss’s advice)?

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10


Sample Output
5
13
-1
-1


Author
hphp


Source
2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU

经典混合背包

第一类,至少选一项,即必须要选,那么在开始时,对于这一组的dp的初值,应该全部赋为负无穷,这样才能保证不会出现都不选的情况。
状态转移方程:

dp[i][j]=max(dp[i][j],max(dp[i][j-w[x]]+p[x],dp[i-1][j-w[x]]+p[x]));
 第二类,最多选一项,即要么不选,一旦选,只能是第一次选。
状态转移方程:

dp[i][j]=max(dp[i][j],dp[i-1][j-w[x]]+p[x]);
第三类,任意选,即不论选不选,选几个都可以。
状态转移方程为:

dp[i][j]=max(dp[i][j],dp[i][j-w[x]]+p[x]);
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf=0x3f3f3f3f;
int n,m,sum;
int w[110],p[110],dp[110][110];
int main()
{
    while(scanf("%d%d",&n,&sum)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int i,j,k,t;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&m,&t);
            for(k=1;k<=m;k++)
            {
                scanf("%d%d",&w[k],&p[k]);
            }
            if(t==0)///至少选一个的01背包问题
            {
                for(j=0;j<=sum;j++)
                    dp[i][j]=-inf;
                for(k=1;k<=m;k++)
                {
                    for(j=sum;j>=w[k];j--)
                        dp[i][j]=max(dp[i][j],max(dp[i][j-w[k]]+p[k],dp[i-1][j-w[k]]+p[k]));

                }
            }
            else if(t==1)///至多选一个的背包问题
            {
                for(j=0;j<=sum;j++)
                    dp[i][j]=dp[i-1][j];
                for(k=1;k<=m;k++)
                    for(j=sum;j>=w[k];j--)
                        dp[i][j]=max(dp[i][j],dp[i-1][j-w[k]]+p[k]);
            }
            else if(t==2)///随便选的01背包
            {
                for(j=0;j<=sum;j++)
                    dp[i][j]=dp[i-1][j];
                for(k=1;k<=m;k++)
                    for(j=sum;j>=w[k];j--)
                        dp[i][j]=max(dp[i][j],dp[i][j-w[k]]+p[k]);
            }
        }
        dp[n][sum]=max(dp[n][sum],-1);
        printf("%d\n",dp[n][sum]);
    }
    return 0;
}
posted @ 2017-11-18 20:51  南风古  阅读(126)  评论(0编辑  收藏  举报