Poj 3461 Oulipo(Kmp)

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38015 Accepted: 15307
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Source
BAPC 2006 Qualification

/*
Kmp裸题.
刚学会kmp算法orz.
next[i]表示i前面与i位置相同字符的字符位置. 
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXN 1000001
using namespace std;
char s1[MAXN],s2[MAXN];
int next[MAXN],l1,l2,ans;
void slove()
{
    for(int i=2;i<=l1;i++)
    {
        int p=next[i-1];
        while(p&&s1[p+1]!=s1[i]) p=next[p];
        if(s1[p+1]==s1[i]) p++;
        next[i]=p;
    }
}
void kmp()
{
    int p=0;
    for(int i=1;i<=l2;i++)
    {
        while(p&&s1[p+1]!=s2[i]) p=next[p];
        if(s1[p+1]==s2[i]) p++;
        if(p==l1) ans++,p=next[p];
    }
    printf("%d\n",ans);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(next,0,sizeof next);ans=0;
        scanf("%s",s1+1);l1=strlen(s1+1);
        scanf("%s",s2+1);l2=strlen(s2+1);
        slove();kmp();
    }
    return 0;
}
posted @ 2017-01-17 21:52  nancheng58  阅读(82)  评论(0编辑  收藏  举报