【PAT甲级】1008 Elevator (20分)

1008 Elevator

题目:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. ②The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. ①Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

注意:

  • 这句句子一开始做题没看懂。


    翻译:每个例子包含一个正整数N,后面跟着N个正整数。

    (第一个数是数字的个数,第二个数串才是输入样例)

① Each case contains a positive integer N, followed by N positive numbers.


  • 每到达一个目标层次,停留5秒。包括最后一个目标层数

    The elevator will stay for 5 seconds at each stop.


  • (在这题目中没有出现,只是突然想到的)


    Java中有方法length()可以直接得到数组的长度;

    在C++中,字符串可以用strlen()得到长度,其他类型的数组用sizeof(数组名)/sizeof(数组的任一元素)




代码:

#include<iostream>
using namespace std;

int main() {
    int n; //N numbers
    cin>>n;

    int time=0;//time time
    int curr=0;//current floor
    int number;
    for(int i=0; i<n; i++) {
        cin>>number;

        if(curr<number) { //go up
            time+=(number-curr)*6+5;
        } else if(curr>number) {//go down
            time+=(curr-number)*4+5;
        } else { //same floor
            time+=5;//stay
            continue;
        }
        curr=number;

    }

    cout<<time<<endl;

    return 0;
}


运行结果:

posted @ 2019-12-17 19:33  musecho  阅读(201)  评论(0编辑  收藏  举报