The server selected protocol version TLS10 is not accepted by client preferences [TLS12] 报错处理

一、问题描述:

        项目工程需求要连接 SqlServer 服务器,但是报错了,完整错误如下:com.microsoft.sqlserver.jdbc.SQLServerException: 驱动程序无法通过使用安全套接字层(SSL)加密与 SQL Server 建立安全连接。错误:“The server selected protocol version TLS10 is not accepted by client preferences [TLS12]”。

翻译成中文:SqlServer 服务器只接受 TLS1.0,但是客户端给的是 TLS1.2。

 

二、问题梳理:

当前工程架构版本如下:

  • SpringBoot: 2.3.2.RELEASE
  • Mybatis-Plus: 3.0.5
  • sqljdbc4: 4.0
  • jdk: 1.8.0_291

 

这里跟“问题描述”有关的就只有 jdk,打开文件:JAVA_HOME\jre\lib\security\java.security,

搜索关键词“jdk.tls”,可以找到配置项:jdk.tls.disabledAlgorithms(jdk不生效的算法配置)里面有TLSv1, 也就是说 TSL1.0版本不让用了,这样就解释了为啥会出现问题。

 三、问题解决

1. 把 jdk.tls.disabledAlgorithms 配置项中 TLSv1 删除,这样  TLS1.0 就可以使用了。

2. 把 jdk.tls.disabledAlgorithms 配置项注释掉或者删掉。

3. 如果嫌麻烦可以直接把 java.security 文件删了,问题可以解决,但是会不会出现其他问题就不得而知了,慎重使用。

备注:网上有让修改 jdk.tls.legacyAlgorithms 配置项的,可能跟我的 jdk 版本不一样,试了并没有效果;如果上述不能解决问题,可以尝试。

 

 

出处:https://blog.csdn.net/qingquanyingyue/article/details/121255647

=======================================================================================

再不行动话,还有一个方法:点击开始菜单,我在“配置java”控制面板中找到了“高级”选项卡。我可以在那里勾选一个复选框来使用TLS1.0或者TLS1.1。

 

参考出处:https://cloud.tencent.com/developer/ask/sof/1122374

======

看到上面两篇文章,和我的比较类似,应该是同一类问题。

我的是在Jenkins中使用svn下载代码的时候,出现了相同的提示:

由于服务器升级,新搭建的Jenkins服务器在输入svn连接和账户密码后,提示Unable to access the repository。点击构建后,构建失败提示:org.tmatesoft.svn.core.SVNException: svn: E175002: SSL handshake failed: ‘The server selected protocol version TLS10 is not accepted by client preferences [TLS12]’

 

  

 

 

解决方法,按上面两篇文章中的方法试试,注意修改了java的配置之后,要重启Jenkins服务


参考:https://blog.csdn.net/liming19890713/article/details/120449521

posted on 2022-04-11 16:33  jack_Meng  阅读(7764)  评论(0编辑  收藏  举报

导航