1099 Build A Binary Search Tree (30 分)(二叉查找树BST)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

image

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

题目大意:

给出一棵二叉搜索树(给出每个结点的左右孩子),且已知根结点为0,求并且给出应该插入这个二叉搜索树的数值,求这棵二叉树的层序遍历

分析:

  1. 用结构体data,left,right表示这棵树的结构,a数组存树的信息,b数组存这棵树节点的所有data,根据输入可知树a[i]的left和right~
  2. 因为是二叉搜索树,所以中序遍历这棵树得到的结点顺序应该是给出的数值序列从小到大的排列顺序,所以把数值序列排序后,可以在中序遍历的时候直接赋值当前a[root].data~同时可得知树的最大层数maxLevel的值~
  3. 二维数组v用来存储每一层的结点下标,一共有0到maxLevel层。用for循环从0开始一层层遍历v,就可以得到下一层的l和r,遍历过程中可以输出每个结点对应的data值a[v[i][j]].data~

原文链接:https://blog.csdn.net/liuchuo/article/details/52181651

题解

image

#include <bits/stdc++.h>

using namespace std;
const int maxn=110;
struct node
{
    int data;
    int lchild,rchild;
}Node[maxn];
int n,in[maxn],num=0;
void inOrder(int root)
{
    if(root==-1) return;
    inOrder(Node[root].lchild);
    Node[root].data=in[num++];
    inOrder(Node[root].rchild);
}
void BFS(int root)
{
    queue<int> q;
    q.push(root);
    num=0;
    while(!q.empty()){
        int now=q.front();
        q.pop();
        cout<<Node[now].data;
        num++;
        if(num<n) cout<<" ";
        if(Node[now].lchild!=-1) q.push(Node[now].lchild);
        if(Node[now].rchild!=-1) q.push(Node[now].rchild);
    }
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int lchild,rchild;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>lchild>>rchild;
        Node[i].lchild=lchild;
        Node[i].rchild=rchild;
    }
    for(int i=0;i<n;i++){
        cin>>in[i];
    }
    sort(in,in+n);
    inOrder(0);
    BFS(0);
    return 0;
}
posted @ 2022-01-05 19:12  勇往直前的力量  阅读(26)  评论(0编辑  收藏  举报