安装Kibana出现的问题

安装Kibana出现的问题

前言

该问题的出现是在安装配置完成之后,也就是说下载好了kibana的相关包,在启动过程中出现的错误,该错误是在centos6的机器上引发的,是因为系统中的GLIBC_2.14版本过低造成的,需要将该包升级到2.17版本,具体错误和版本升级操作如下:

FATAL  Error: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/kibana/kibana-7.2.0-linux-x86_64/node_modules/@elastic/nodegit/build/Release/nodegit.node)

问题解决连接:https://blog.csdn.net/reblue520/article/details/97716560

下面是主要对问题进行记录,防止后面出现的时候找不到该地址:

$ wget http://ftp.gnu.org/gnu/glibc/glibc-2.17.tar.gz
$ tar -xf glibc-2.17.tar.gz
$ cd glibc-2.17
$ mkdir build
#在进行预编译过程中需要安装编译器
$ sudo yum -y install gcc-c++
$ cd build
$  ../configure --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin  #预编译
$ make -j 4				#多线程编译
$ make  install
$ strings /lib64/libc.so.6 | grep GLIBC  #查看版本信息

如上内容操作完成之后然后重新启动Kibana就能够启动成功了

posted @ 2019-09-09 16:50  墨迹塔  阅读(1126)  评论(0编辑  收藏  举报