pip 安装超时解决方案

已经使用梯子,安装某依赖时仍然超时。

首先检查pip的版本是否需要更新,如果不是最新版本运行命令更新:

python -m pip install --upgrade pip

如果仍然超时错误,则运行命令(packageName换成需要安装的依赖包名):

pip --default-timeout=100 install -U [packageName]

即可成功。

posted @ 2017-06-14 11:15  明潭  阅读(...)  评论(...编辑  收藏