随笔分类 - PhoneGap

摘要: <!DOCTYPE html><html><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><meta name="viewport" id="viewport" content="width=device-width,height=device-height,initial-scale=1.0,user-scalable=no"><s阅读全文
posted @ 2013-03-05 14:37 残星 阅读(304) | 评论 (0) 编辑
摘要: Connection“Connection对象提供对设备的蜂窝及WiFi连接信息的访问。通过navigator.network接口访问该对象。属性:connection.type常量:connection.UNKNOWNconnection.ETHERNETconnection.WIFIconnection.CELL_2Gconnection.CELL_3Gconnection.CELL_4Gconnection.NONEconnection.type检查正在使用的活动网络连接。说明:该属性是确定设备网络连接状态和连接类型的快速方法。 支持的平台:iOSAndroidBlackBerry We阅读全文
posted @ 2013-03-05 13:17 残星 阅读(250) | 评论 (0) 编辑
摘要: PhoneGap API帮助文档翻译Notification提醒是本文要介绍的内容,主要是来了解PhoneGap API文档的内容,具体PhoneGap API文档内容的详解来看本文,设备的视觉、听觉和触觉通知。方法:notification.alert notification.confirm notification.beep notification.vibrate notification.alert显示一个定制的警告或对话框。navigator.notification.alert(message,alertCallback,[title],[buttonName]); naviga阅读全文
posted @ 2013-03-04 16:11 残星 阅读(220) | 评论 (0) 编辑
摘要: <script type="text/javascript" charset="utf-8" > //Sample use: /** * Display an intent to play the video. * * @param url The url to play */ //play(url) //window.plugins.videoPlayer.play("http://path.to.my/video.mp4"); //window.plugins.videoPlayer.play("file:/阅读全文
posted @ 2013-02-01 14:38 残星 阅读(1837) | 评论 (0) 编辑
摘要: 1. 需求Eclipse 3.4+本教程还有另外一个不使用Eclipse的版本,参照这里。2. 安装SDK + PhoneGap下载并安装Eclipse Classic。下载并安装Android SDK。下载并安装ADT Plugin。下载最新版本的PhoneGap并解压,我们将使用其中的Android目录。3. 新项目设置启动Eclipse,然后在菜单“File”下选择“New > Android Project”。在项目根目录下,创建两个新目录:/libs/assets/www复制phonegap.js(从PhoneGap解压缩后的Android目录中,将解压缩后的带版本号的js文件阅读全文
posted @ 2013-01-29 17:51 残星 阅读(374) | 评论 (0) 编辑
摘要: 1,openDatabasephonegap官方文档中已经很清楚的标明,如果使用一个数据库首先要用window对象进行创建:var dbShell = window.openDatabase(name, version, display_name, size);参数:name:标明数据库的名称version:版本号display_name:显示名称,与name的区别在于数据库表中,分别有这两个字段。size:数据库的大小详解:之前,在利用工厂模式,创建了一个数据库对象:function db(name,ver,dis,size){.......var _db = window.openData阅读全文
posted @ 2013-01-29 17:39 残星 阅读(8622) | 评论 (1) 编辑
摘要: 今天想重新搭建一个phonegap环境,用eclipse+phonegap,使用的是corvada1.7.0版本,ADT是17,基于android2.2第一次搭建失败,很奇怪,不知道哪里出错,总是无法正常运行。官方上的文档也不可全信啊。急死人了。刚刚弄好了,可能是以前没有严格按照官方要求去做,顺序什么的有问题,又重新做了一遍,现在可以了。下面是步骤,以后会尝试用dreaweav搭建一个phonegap环境:1、打开 Eclipse,在文件菜单下面点击 New > Android Project这里的packagename可以填写自己想要的名字,下面点击完成就可以了。2、在项目的根目录, 阅读全文
posted @ 2013-01-28 20:32 残星 阅读(3283) | 评论 (0) 编辑