Light, more light - PC110701

欢迎访问我的新博客:http://www.milkcu.com/blog/

原文地址:http://www.milkcu.com/blog/archives/uva10110.html

原创:Light, more light - PC110701

作者:MilkCu

题目描述

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off? 
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output "yes" if the light is on otherwise "no" , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

Sadi Khan 
Suman Mahbub 
01-04-2001

解题思路

任一整数,它可能为平方数或非平方数。
若为非平方数,则它的因子总是成对出现的,即因子个数为偶数;
若为平方数,则它的因子个数为奇数。
也就是说:
如果n为非平方数,则灯的状态为关;
如果n为平方数,则灯的状态为开。

刚开始评测一直说是错误的答案,可能是因为数据类型和头文件的问题。

代码实现

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int main(void) {
	while(1) {
		long long n;
		cin >> n;
		if(n == 0) {
			break;
		}
		long long tmp = sqrt(n);
		if(n == tmp * tmp) {
			cout << "yes" << endl; 
		} else {
			cout << "no" << endl;
		}
	}
	return 0;
}

(全文完)

本文地址:http://blog.csdn.net/milkcu/article/details/23543557

posted @ 2014-04-12 17:41  MilkCu  阅读(212)  评论(0编辑  收藏  举报