SQL SERVER 给登陆帐号赋予全部查看Object权限
摘要:GRANT View DEFINITION to <user_login_account>
阅读全文
SQL Server 2005 修改系统表
摘要:在SQL Server 2005中, 要修改系统表, 需要以下步骤:首先, 需要以单用户模式启动SQL Server, 脚本如下:sqlservr -s<SQLInstanceName> -m (其中, 将真正的数据库实例名替换<SQLInstanceName>)注意, 参数-s及-m要注意大小写, 正确应该都是小写, 全都用大写会报错, 其它情况没试过, 不知道为什么.其次, 以以下脚本连接数据库sqlcmd -E -S <ComputerName>\<SQLInstanceName> -A (其中, 将真正的电脑名替换<Computer
阅读全文
posted @
2010-03-31 21:15
黑暗之眼
阅读(399)
推荐(0)
如何启动Reporting Service远程错误
摘要:修改ReportServer数据库的ConfigurationInfo表, 修改 EnableRemoteErrors 的值, 设为True, 之后, 重启Server, 重启SQL Server Service或Reporting Service无效.
阅读全文
posted @
2010-03-18 13:34
黑暗之眼
阅读(251)
推荐(0)
Get DBID
摘要:SELECT DB_ID('CNCTS01') as [Database ID]
阅读全文
查看SQL Server的Version,Edition and patch
摘要:SELECT SERVERPROPERTY('productversion'), SERVERPROPERTY ('productlevel'), SERVERPROPERTY ('edition')
阅读全文
posted @
2010-02-02 14:36
黑暗之眼
阅读(152)
推荐(0)
SQL Server 2000 database change name
摘要:此贴转自http://www.yongfa365.com/Item/SQL-Server-2000-Change-Database-Name-Success-yongfa365.html把Old数据库改为New数据库打开“企业管理器”找到 Old数据库--》右键--》所有任务--》分离数据库然后到C:\Program Files\Microsoft SQL Server\M...
阅读全文
posted @
2010-01-27 21:11
黑暗之眼
阅读(287)
推荐(0)
查看某一特定用户在数据库中拥有的权限
摘要:sp_helprotect null,'OTS_Interface_User'
阅读全文
posted @
2010-01-07 13:36
黑暗之眼
阅读(178)
推荐(0)
找回Builtin\Administrators
摘要:使用系统管理员登陆, 并调用以下SPsp_grantlogin 'builtin\administrators'
阅读全文
posted @
2009-12-22 18:41
黑暗之眼
阅读(91)
推荐(0)
SQL Server 日志文件大小清零 2008-12-16
摘要:backup log dbName with NO_LOGbackup log dbName with TRUNCATE_ONLYDBCC SHRINKDATABASE(dbName) 以上方式仅限于SQL 2005以前版本SQL 2008 则要使用以下新方式:USE DatabaseNameGO-- Truncate the log by changing the database recove...
阅读全文
posted @
2008-12-16 13:04
黑暗之眼
阅读(233)
推荐(0)