poj2594最小路径覆盖+floyd

Treasure Exploration
Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 8909   Accepted: 3644

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

Source

 

与一般最小路径的区别就是这个点可以属于两个及以上不同的路径之中

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=508;
const int M=3e5+88;
bool mp[N][N],vis[N];
int used[N],head[N],tot,n;
struct node
{
    int to,next;
} e[M];
void add(int u,int v){
   e[tot].to=v;e[tot].next=head[u];head[u]=tot++;
}
bool findx(int u)
{
    for(int i=head[u]; ~i; i=e[i].next)
    {
        int v=e[i].to;
        if(vis[v]) continue;
        vis[v]=1;
        if(!used[v]||findx(used[v]))
        {
            used[v]=u;
            return true;
        }
    }
    return false;
}
void floyd()
{
    for(int i=1; i<=n; ++i) for(int j=1; j<=n; ++j) for(int k=1; k<=n; ++k)
                mp[i][j]=mp[i][j]|(mp[i][k]&&mp[k][j]);
}
int main()
{
    int m,x,y;
    while(scanf("%d%d",&n,&m),n||m)
    {
        tot=0;
        memset(mp,0,sizeof(mp));
        memset(used,0,sizeof(used));
        memset(head,-1,sizeof(head));
        while(m--)
        {
            scanf("%d%d",&x,&y);
            mp[x][y]=1;
        }
        floyd();
        int maxmatch=0;
        for(int i=1; i<=n; ++i) for(int j=1; j<=n; ++j) if(mp[i][j]) add(i,j);
        for(int i=1; i<=n; ++i)
        {
            memset(vis,0,sizeof(vis));
            if(findx(i)) ++maxmatch;
        }
        printf("%d\n",n-maxmatch);
    }
}

 

posted @ 2017-09-29 23:35  Billyshuai  阅读(128)  评论(0编辑  收藏  举报