hdu6090 菊花图

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 239    Accepted Submission(s): 157


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j) ) as the length of the shortest path between i and j . The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j , we make dist(i,j) equal to n .

Then, we can define the weight of the graph G (wG ) as ni=1nj=1dist(i,j) .

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(ij) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG .

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4) .
 

 

Input
The first line contains a number t(1t10) , the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n106,1m1012) .
 

 

Output
For each testcase, print a single line with a single number -- the answer.
 

 

Sample Input
1
4 5
 

 

Sample Output
14

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    for(scanf("%d",&T); T--;)
    {
        long long  n,m;
        scanf("%I64d%I64d",&n,&m);
        long long maxx=n*(n-1)/2;
        if(m>=maxx) printf("%I64d\n",maxx*2);
        else if(m>=n-1)  printf("%I64d\n",2*(n-1)*(n-1)-2*(m-n+1));
        else printf("%I64d\n",2*m*m+(n-m-1)*(m+1)*n*2+(n-m-1)*(n-m-2)*n);
    }
}

 

 
posted @ 2017-08-08 20:59  Billyshuai  阅读(233)  评论(0编辑  收藏  举报